Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to run a PHP script from the webserver that executes other scripts and programs. When I run it manually, everything works fine, but when I run it from the webserver, it doesn't seem to execute it, though I get no error messages. Could be a permissions issue? If so, how can I fix it? If not, well, how do I fix it?

share|improve this question
    
Which web server software? –  Harry Johnston Oct 8 '11 at 0:34
add comment

1 Answer

If the errorlog shows nothing of value i usually resort to procmon wich should give you a good hint to find the problem. just start procmon, execute the script through apache2, stop procmon and search for the scriptname or filter accordingly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.