Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have PHP 5.3.5 on Ubuntu Sever and I need to have exactly 5.3.8. How can I do such an upgrade?

ps. Just question just earned "notable question" badge, any reasons for the downvotes?

share|improve this question

closed as not constructive by voretaq7 Dec 14 '12 at 17:09

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
How about "this question does not show any research effort"? –  MadHatter Dec 14 '12 at 12:16

3 Answers 3

download from php.net and compile. or http://www.dotdeb.org/2011/08/30/php-5-3-8-is-available/

share|improve this answer
    
compiling is a bad thing (tm) –  GioMac Dec 14 '12 at 14:59
    
    
Yes it is wrong! You will never know, even if you are Zend employee: how many binary files will you get, where will "make install" put them, how to upgrade them (which files to remove, which to leave), you cannot be sure how "make uninstall" and "make install" will upgrade it, you do not know which files were changed by you. YOU JUST CANNOT KNOW THAT. This is why packaging like RPM and DPKG is used. Compile in RPM, not in the air. –  GioMac Dec 19 '12 at 11:31

Maybe you should search from some Ubuntu custom repositories which already has latest PHP versions and maybe also PHP beta versions and you can install it from there without the hassle of downloading and compiling it manually.

share|improve this answer
    
But how do I specify to install the version I need? E.g. now I have 5.3.5, but want 5.3.3? –  takeshin Oct 9 '11 at 20:57
    
what ubuntu version are you using? i386 or amd64? –  Nelimitat Media Oct 9 '11 at 21:35

We first have to resolve two dependencies required for the dotdeb packages. If you are running the amd64 version, you should replace i386 with amd64.

cd /tmp

wget http://us.archive.ubuntu.com/ubuntu/pool/main/k/krb5/libkrb53_1.6.dfsg.4~beta1-5ubuntu2_i386.deb

wget http://us.archive.ubuntu.com/ubuntu/pool/main/i/icu/libicu38_3.8-6ubuntu0.2_i386.deb

sudo dpkg -i *.deb

We'll have to add the dotdeb repository to the APT sources, so we can use their packaged PHP 5.3 and php-fpm:

sudo echo "deb http://php53.dotdeb.org stable all" >> /etc/apt/sources.list

Update apt:

sudo apt-get update

The resulting text should include dotdeb.

Now we'll install PHP (part 1):

sudo apt-get install php5-cli php5-common php5-suhosin
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.