Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have php 5.3.6 installed on Centos 5.5 (from iucommunity repository). Now when I want to enable dBase by yum install php-dbase, I get this error:

Package php-dbase is obsoleted by php-common, trying to install php-common-5.1.6-27.el5_5.3.i386 instead
Package matching php-common-5.1.6.27.el5_5.3.i386 already installed. Checking for update.
Nothing to do

Probably, because I have installed php with yum install php53. How can I enable dBase on my current server?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

As it said, php-dbase is obsoleted and you should install php53-common instead:

# yum --enablerepo=iuscommunity install php53-common
share|improve this answer
    
but php53-common has already been installed –  All Oct 9 '11 at 9:26
    
What do you want to do with php-dbase? –  quanta Oct 9 '11 at 9:34
    
Although it is an old system with no interesting feature; but I believe it is quite fast for simple storage on flatfile (e.g. one column data in the form of key/value where key is ID which is identical to line number). –  All Oct 9 '11 at 9:48

Are you sure that the function calls are actually not there? Try calling them - it sounds like they are already part of common now.

share|improve this answer
    
Yes, the library of dbase does not exist in php extensions. When running a dbase command, I get error of "Fatal error: Call to undefined function dbase_create()" –  All Oct 9 '11 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.