Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm not a new User... but i lost my Login Info. Don't know why it's says that i'm new here. Maybe a new section. ANYWAY...

I have moved My Site to a new Shered windows Server. and i getting this Error with any aspx file.

Server Error in '/' Application.
Runtime Error

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
    <customErrors mode="Off"/>
</system.web>
</configuration>


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Please See Example: http://picit.co.il/test.aspx

It was working perfectly in the old server.

This is my Web.config file.

<?xml version="1.0"?>
<configuration>
<appSettings>
    <add key="SiteAddress" value="http://www.picit.co.il/" />
    <add key="EMAIL_HOST" value="mail.barak.net.il"/>
    <add key="EMAIL_CONTACT_NAME" value="PicIt"/>
    <add key="EMAIL_USER" value="bonsite-barak.net.il"/>
    <add key="EMAIL_PASS" value="013013"/>
    <add key="MASTER_USERNAME" value="picit"/>
    <add key="MASTER_PASSWORD" value="2hH4HeC3"/>

    <add key="FCKeditor:UserFilesPath" value="~/Up/Main/"/>
    <add key="FCKeditor:BasePath" value="~/Controls/FCKeditor/"/>
</appSettings>
<connectionStrings>
    <add name="Con" connectionString="Data Source=127.0.0.1;Initial Catalog=picitDB;user=User;password=Password;" providerName="System.Data.SqlClient"/>
</connectionStrings>
<system.web>
    <customErrors mode="Off"/>
    <globalization culture="he-IL" uiCulture="he-IL"/>
    <sessionState mode="InProc"/>
    <identity impersonate="true"/>
    <authentication mode="Windows"/>
    <httpRuntime maxRequestLength="22000"
minFreeThreads="16"
executionTimeout="500"
useFullyQualifiedRedirectUrl="false"
minLocalRequestFreeThreads="4"
appRequestQueueLimit="1000" />
    <pages theme="Front">
        <namespaces>
            <add namespace="Website"/>
        </namespaces>
        <controls>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" namespace="System.Web.UI" tagPrefix="asp"/>
            <add tagPrefix="Upload" namespace="Brettle.Web.NeatUpload" assembly="Brettle.Web.NeatUpload"/>
            <add tagPrefix="fck" namespace="FredCK.FCKeditorV2" assembly="FredCK.FCKeditorV2"/>
            <add tagPrefix="swf" tagName="movie" src="~/Controls/swf.ascx"/>
            <add tagPrefix="Btn" tagName="Friend" src="~/Controls/btn_friend.ascx"/>
            <add assembly="Bound" namespace="CustomControls" tagPrefix="asp"/>
            <add assembly="skmValidators" namespace="skmValidators" tagPrefix="Vld"/>

            <add tagPrefix="CC" tagName="Upload" src="~/Controls/upload.ascx"/>
        </controls>
    </pages>
    <compilation debug="true">
        <assemblies>
            <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </assemblies>
    </compilation>
    <httpModules>
        <add name="UploadHttpModule" type="Brettle.Web.NeatUpload.UploadHttpModule, Brettle.Web.NeatUpload"/>
        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </httpModules>
    <httpHandlers>
        <remove verb="*" path="*.asmx"/>
        <add verb="*" path="*.asmx" validate="false"     type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions,     Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add verb="GET,HEAD" path="ScriptResource.axd"     type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,     Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
            <add verb="GET" path="ScriptResource.axd"     type="Microsoft.Web.Handlers.ScriptResourceHandler" validate="false"/>
    </httpHandlers>
</system.web>
<system.webServer>
    <modules>
        <add name="UploadHttpModule"     type="Brettle.Web.NeatUpload.UploadHttpModule, Brettle.Web.NeatUpload"     preCondition="managedHandler"/>
        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule,     System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,     PublicKeyToken=31bf3856ad364e35" preCondition="managedHandler"/>
    </modules>
    <handlers>
        <add name="ScriptResource.axd_GET" path="ScriptResource.axd"     verb="GET" type="Microsoft.Web.Handlers.ScriptResourceHandler"     preCondition="integratedMode,runtimeVersionv2.0"/>
        <add name="ScriptResource.axd_GET,HEAD" path="ScriptResource.axd"     verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,         Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"     preCondition="integratedMode,runtimeVersionv2.0"/>
        <add name="*.asmx_*" path="*.asmx" verb="*"     type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions,     Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"     preCondition="integratedMode,runtimeVersionv2.0"/>
    </handlers>
    <validation validateIntegratedModeConfiguration="false"/>
</system.webServer>
</configuration>
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.