Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a heck of a time finding any support for this. I'd like to enable 3D support for a natty instance. The option is grayed out. Is there some magic voodoo that I have to perform to enable this option?

enter image description here

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Sorry, 3D acceleration for Linux guests is not available with this version of VMware. It was only just added with the recent release of Workstation 9. I haven't yet been able to confirm that it's available in vSphere Hypervisor 5.1 (formerly known as ESXi) though I suspect it would be.

share|improve this answer
add comment

Please have a check here:

http://communities.vmware.com/thread/327250

Enable 3D Support checkbox will be shown on Video card settings page in Virtual Machine Properties dialog. If the host does not support 3D the checkbox will be disabled. 3D checkbox will be enabled only if the following requirements must be met:

  1. The host supports 3D acceleration
  2. The host OS supports 3D acceleration i.e. meaning ESX 5.0 and higher.
  3. The VM HW version is 8 and higher.

Once you enable the 3D support in the VM, power it on, once booted, make sure all your DirectX features are enabled .i.e following should be enabled :

  1. DirectDrow Acceleration
  2. Direct3D Acceleration
  3. AGP Texture Acceleration.

you can use DirectX Diagnostic Tool to do this. In Windows 7, it should be Enabled by default if the proper H/W is presented to it.

Once this is done, the installation and operatations of 3D Studio Max 2012 should go smooth.

share|improve this answer
    
Please next time include the relevant parts of the link in your post. –  Lucas Kauffman Jul 23 '12 at 6:26
add comment

In my experience my host does support 3D acceleration yet is unavailable when I use the template for Windows Server 2008 R2 if I switch to the Windows 7 Template the 3D acceleration works flawlessly. You could try selecting a different OS template and try it that way. EDIT: you can also add "mks.enable3d=true" to the vmx file using Configurations Paramaters under options > general on the edit settings screen of the virtual pc.

share|improve this answer
    
Might be helpful if the OP wasn't asking about how to do this on Ubuntu, and not "a different OS." –  HopelessN00b Oct 8 '12 at 1:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.