Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am getting an error from squid

WARNING! Your cache is running out of filedescriptors

What should i do in my mac to prevent this error?

share|improve this question

1 Answer 1

I think you can use something similar to:

# sysctl -w kern.maxfiles = nr
# sysctl -w kern.maxfileperproc = nr

To make it persistent edit /etc/sysctl.conf like this

kern.maxfiles=nr
kern.maxfileperproc = nr

Later method needs reboot or reload via sysctl.

You may also need to raise the ulimit settings for regular users:

ulimit -S n nr
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.