Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can ssh into one of my servers, I log in fine, but at the prompt I cannot type anything. It just hangs there after the welcome message.

I've also tried the DRAC console (its a Dell server), but I get a blank dark screen without any output when I call up a remote console.

I cannot reboot this machine at this time nor am I physically near it. I've tried to log in as all root as well without any luck. The box itself functions ok at the moment but I'm now worried as this is a critical production machine.

What can be the cause of this?

share|improve this question
What happens if you execute command like this: $ ssh -t -t user@ip "w"? – quanta Oct 10 '11 at 10:22
I get the output of w, showing my stuck logins: 11:13:47 up 128 days, 17:59, 3 users, load average: 6.44, 6.03, 5.01 USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT harel pts/0 hulk 10:08 1:05m 0.25s 0.25s -bash root pts/4 hulk 10:56 17:02 0.11s 0.11s -bash harel pts/6 hulk 11:13 0.00s 0.00s 0.00s w – Harel Oct 10 '11 at 10:26
But its inconsistent. Seems like its down to chance: other commands I run, including a rerun of your "w" fail in the same way. – Harel Oct 10 '11 at 10:36
Did you try with another user or from different machine? – quanta Oct 10 '11 at 10:40
can you get the output of a df, see if any of the drives are full (particularly wherever you keep logs). – Chris S Oct 10 '11 at 12:48
up vote 1 down vote accepted

From the comment discussion this sounds like the behavior you see when you are experiencing packet loss due to MTU/fragmentation issues:

This usually shows up as being able to login to the machine but some commands fail (usually a significant percentage of the time). You can verify that this isn't the issue by getting the same behavior on a machine connected to the same LAN as the box having the problems. If that session works fine, then you probably need to start looking at the network layer between you and the machine in question.

share|improve this answer
I think you might be right. A reboot of the server resolved the problem. Its the first I've ever seen it, and that server has been online for about 128 days before that hit it. Other servers on same subnet were fine. – Harel Oct 11 '11 at 8:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.