Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run a server with Ubuntu Server 11.04 x64.

Ever since I set up that server from scratch configuring it with RAID 1 (software), I have been getting this error in email from the daily cronjobs.

    A DegradedArray event had been detected on md device /dev/md/0.

    Faithfully yours, etc.

    P.S. The /proc/mdstat file currently contains the following:

    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md0 : active raid1 sda1[0]
      248820 blocks super 1.2 [2/1] [U_]

    unused devices: <none>
share|improve this question

You are missing a drive in your RAID array.

248820 blocks super 1.2 [2/1] [U_]

That line right there tells you the issue.

Check your DMESG and see if it's detecting your other disk, also with software Raid I run smartmon on all my drives to make sure they are ok. You could have had your second disk go bad, and you didnt know it.

Now to fix this you just need to run this command, assuming your second drive of your array is sdb.

mdadm --manage /dev/md0 --add /dev/sdb1

share|improve this answer
I just ran the command, mdadm --manage /dev/md0 -add /dev/sbd. Now it shows, [2/2] [UU] – Dennis Linuz Oct 10 '11 at 18:05
It looks like that fixed it and added in your missing drive. – Squidly Oct 10 '11 at 20:12

It means the mirror is broken — only sda1 still be in the RAID. You can try adding the 2nd disk into in with mdadm /dev/md/0 -a /dev/2ND_DISK_NAME_PART_NUM, IIRC.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.