Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to install Exchange 2010 on a fresh install of Server 2008. I believe I have all of the server roles and features configured properly, however I am getting this error:


Summary: 12 item(s). 0 succeeded, 1 failed. Elapsed time: 00:04:07

Organization Preparation Failed

Error: The following error was generated when "$error.Clear();

      $acceptedDomains = @{};
      Get-AcceptedDomain | foreach {
          $domainName = $_.DomainName.ToString();
          if ($acceptedDomains.Contains($domainName)) {
              Write-ExchangeSetupLog -Warning "Duplicate AcceptedDomain found.  '$($acceptedDomains[$domainName])' and '$($_.Name)' both reference domain '$domainName'";
          } else {
              $acceptedDomains.Add($domainName, $_.Name);
          };
      };

      function getSmtpTemplates ([string]$property)
      {
          $input |
              Select-Object -ExpandProperty $property |
              Where-Object {$_.PrefixString -eq "SMTP"} |
              Foreach-Object {$_.AddressTemplateString -replace ".*@", ""};
      }


      function addDomains ([Microsoft.Exchange.Data.Directory.SystemConfiguration.AcceptedDomainType]$domainType)
      {
          $domain = $null;
          $input |
              Where-Object {-not $acceptedDomains.ContainsKey($_)} |
              Where-Object {[Microsoft.Exchange.Data.SmtpDomainWithSubdomains]::TryParse($_, [ref] $domain)} |
              Foreach-Object {
                  $name = $domain.ToString();
                  if ($name.Length -gt 64) { $name = $name.Substring(0, 64) };
                  if ($acceptedDomains.ContainsValue($name) ) {$name = [System.Guid]::NewGuid().ToString()};

                  new-AcceptedDomain -Name:$name -DomainName:$domain -DomainType:$domainType;
                  $acceptedDomains[$domain.ToString()] = $name;
              };
      }

      $emailAddressPolicies = Get-EmailAddressPolicy;
      $emailAddressPolicies | getSmtpTemplates "NonAuthoritativeDomains" | addDomains "InternalRelay";
      $emailAddressPolicies | getSmtpTemplates "EnabledEmailAddressTemplates" | addDomains "Authoritative";
    " was run: "The property value is invalid. The value can't contain leading or trailing whitespace. Property Name: Name".

The property value is invalid. The value can't contain leading or trailing whitespace. Property Name: Name Elapsed Time: 00:04:07


Any help would be greatly appreciated!

share|improve this question
    
I have fixed what I thought was the problem, namely a "\" in the CN= object. Still didn't fix it. I ran exchange health check tool and pre-deployment tool which passed. I'm stumped. –  AdamF Oct 10 '11 at 21:14

1 Answer 1

This was a known issue in Exchange 2007, where the DN in one of your recipient policies contained a rogue whitespace.

Check out this http://technet.microsoft.com/en-us/library/dd233089(EXCHG.80).aspx and see what's in your policies using ADSIedit.

share|improve this answer
    
Hi, and thanks. when I go to ADSIedit, CN=Services / CN<org name> / there is a rogue "\" character, which indicated a white space. The problem is, I can't edit it because it's owned by the system. That technet article says to edit it using the Exchange Management Console, but the EMC won't even install. –  AdamF Oct 10 '11 at 16:55
    
Can you install the EMC on any other machine (even your own PC?). You should be able to strip the install back to just the EMC. –  George Hewitt Oct 10 '11 at 17:00
    
Hi George, I stripped the install just to the EMC by using the "custom installation" and only checking "Exchange Management Console." Unfortunately I got the same error. I can see what the issue is (rogue "\" character), but it won't let me resolve it without the EMC. Frustrating! :) –  AdamF Oct 10 '11 at 17:06
    
Is this as an upgrade from 2007? If so do you have a 2007 EMC somewhere? –  George Hewitt Oct 10 '11 at 17:12
    
No, this is a fresh install of SVR 2008, and brand new Exchange 2010. But I do have an Exchange Server 2003 currently running on another physical server. –  AdamF Oct 10 '11 at 17:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.