Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a subdomain something like dev.something.root.com where I get a connection timeout. If I ping dev.something.root.com , it returns the ip address of the server. If I enter the IP address in the hosts file, then I can access the site. If I take it out - I can no longer access the site.

So it doesn't seem like there's a problem with the site, and the domain seems to be resolving the correct IP.

The request doesn't get all the way to IIS I think, as it's not logging anything.

What could I do to find out the problem ?

Edit

Why would it work when I add the ip to the hosts file ?

share|improve this question

1 Answer 1

Well since DNS is resolving to the correct IP address, DNS is good. Now you'll simply have to make use of host headers in IIS.

More information can be found here.

To add a Web site using a host header identifier using the Web Site Creation Wizard
1. In IIS Manager, expand the local computer, right-click the Web Sites directory, point to New, and then click Web Site.
2. Click Next.
3. In the Description box, type the name you have selected for the Web site, and then click Next.
4. In the Enter the IP address to use for this Web site box, click the IP address used by all sites on the server.
5. In the TCP port this Web site should use box, type the port number used by all sites on the server.
6. In the Host Header for this Web site (Default:None) box, type the host header name to identify the Web site. The host header name must contain the full name of the site, for example, dev.something.root.com.
7. If SSL encryption is not enabled on the server, the SSL port box does not appear. If SSL encryption is enabled on the server, type the SSL port number, and then click Next. Note that you cannot use host headers with SSL encryption.
8. In the Path box, type or browse to the path of your Web site home directory.
9. To create a secured or private Web site, clear the Allow anonymous access to this Web site check box, and click Next. (Web sites are configured for anonymous access by default.)
10. In the Web Site Access Permissions box, set the permissions for the home directory.
11. Click Next, and then click Finish.
share|improve this answer
    
I added more details to my post ... this subdomains has a php site behind it. could that be a cause for the problem ? –  sirrocco Oct 11 '11 at 5:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.