Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Our current network is vlan'd, and the wifi network is on its own separate vlan (130). To connect to the 130 vlan, you connect to the access point (a HP MSM310), which is connected to an HP Procurve 2510-48G switch. In order to do some testing, a developer requires a box on the 130 subnet, that can be accessed by wireless hosts.

The issue is that clients connected directly to the switch on a port set to the 130 vlan can talk to each other absolutely fine.

For example, my laptop is connected to port 37 on the switch. That port is set as 'untagged' on vlan 130. There is a server connected to port 38 (also untagged, vlan 130). They can contact each other fine. The AP is connected to port 43, tagged vlan 130 and 138, though setting port 43 as untagged 130 doesn't resolve the issue.

I'm currently trying to determine whether this is an issue with the access point or the switch. I'd imagine it's the AP, as comms between hosts wired directly works fine.

===== SOLVED =====

As Bart mentioned, it was an issue with the AP isolating clients. The location of this setting was rather awkward to find. From the VSC tab on the AP's web interface, had to click the community's name, and edit the 'Wireless Security Filters'. Fixed the issue by turning this off, though I'm looking in to setting it a little more securely. There's a 'custom' box, that would allow me to specify only certain boxes rather than 'everyone can contact everyone' mode.

share|improve this question
    
Is AP/Client Isolation turned on, on the AP maybe? –  Bart De Vos Oct 11 '11 at 9:24
1  
You got it, Bart. –  s3krit Oct 11 '11 at 9:33
    
Answer in 4 minutes? Not bad, guys, not bad. –  tombull89 Oct 11 '11 at 9:40
add comment

1 Answer

up vote 4 down vote accepted

Make sure to turn off AP/Client Isolation on the AP. ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.