Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a CentOS server which I had to reboot.

However, after the reboot I found myself unable to install wordpress plugins via its admin control panel, as I'm getting a 'failed to connect' message:

wordpress install new plugins page screenshot

This is strange since the the same configuration worked before the reboot.

Any ideas on what can be the problem?

share|improve this question
    
Could you connect to the server via ssh and give us the output for the following commands: iptables -L -v -n, chkconfig --list and netstat -an? Make sure you do this with the appropriate rights (sudo/su) –  Bart De Vos Oct 11 '11 at 9:38
    
Thank you. I ran these commands, but isn't it a little problematic - security wise - to upload the output to here as they include our IP addresses? Also, the outputs of the last 2 commands are very long. What do you say? –  Lea Cohen Oct 11 '11 at 9:57
    
Filter out the IPs if you want, no problem. In chkconfig --list look for a line with FTP. In netstat look for lines containing ftp, 20 or 21. –  Bart De Vos Oct 11 '11 at 10:01
    
ps -ef | grep ftp? –  quanta Oct 11 '11 at 10:08
    
The chkconfig --list output that has ftp in it is this: vsftpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off. netstat's output doesn't give me anything containingftp, 20 or 21 –  Lea Cohen Oct 11 '11 at 10:34
add comment

1 Answer

up vote 1 down vote accepted
vsftpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

It means that vsftpd is not starting at boot. Execute the following commands as root:

/etc/init.d/vsftpd start
chkconfig vsftpd on
share|improve this answer
    
Thank you, That solved the problem! Do you have an idea what we could do to avoid this in the future? –  Lea Cohen Oct 11 '11 at 10:59
1  
chkconfig vsftpd on already makes it is starting at boot. –  quanta Oct 11 '11 at 11:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.