Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a fresh Windows 2008 domain with one DC (DHCP, AD, DNS, WDS). Everything worked fine yesterday at the implementation day, but this morning all hell broke loose.

Some workstation coudn't connect to the AD.. So I logged in as local admin and viewed the ipconfig and saw that the subnet was set to 0.0.0.0. And when I tried to ping I got a warning about sockets cound't load and that I nedd to contact my administrator.

How can this happen? Is there something wrong with my DHCP? Reconfigure DHCP? Or is it something else? Or can it be because I use the software policy with MSI? That the msi installers ruined the windows system?

share|improve this question
    
What MSI-installers? Did you assign a static IP to the server? How large is the DHCP-Pool? How many PCs need to get an IP? How is the network-topology (Switches/routers/Vlans,...)? –  Bart De Vos Oct 11 '11 at 9:57
    
GPO software distrubution. I made custom MSI packets. All servers have static ip's. DHCP pool: 192.168.0.0 /24 (and then excludes for VPN, servers, printers). 50 PC's. 6 Servers (1 DC). No VLAN's, 1 router 4 switches. Fully connected topology. I think that it is the MSI packet that ruins the registery/system or something, because i can't even start the network adapter, IE9 and explorer (crashes). –  Sven Oct 11 '11 at 10:38
    
It sure looks like some faulty MSIs then. Any way to revert the changes and test? –  Bart De Vos Oct 11 '11 at 10:53
1  
Did so, but still crashing applications. I'm reinstalling the OS through WDS. I removed the custom MSI packets from the GPO. Looks like that's the problem because the fresh workstations are working good so far.... fingers crossed :P –  Sven Oct 11 '11 at 11:30
    
All hell broke lose here this afternoon.. The DC had the same thing, even worse (maby because it's a win server) because the lan adapter was no where to be found. Reason for that is the not wanting to start 'network connection' service (don't know if thats the exact name) because of some not starting dependencies and that RPC or something was running. :S something killed my clean windows 2008 server with NOD32.. And the only thing on it what was odd is.. the custom msi packets (already removed it after the GPO removal) but it was on it.. Can't lay my finger on it. –  Sven Oct 13 '11 at 17:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.