Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed VirtualBox on Win7, and created a new VM with Win2008. This seems to be working OK.

I'm now interested in remote desktop from my Win7 to the VM, but can't get that to work. Can anyone help me?

I tried to use 127.0.0.2:3389, as mentioned in the virtualbox doc: http://www.virtualbox.org/manual/ch07.html#rdp-viewers

When I try to connect, it seems like the address is found, but can connect with the standard Administrator account.

I am thinking there are some network configurations here that I'm missing? Any help will be appreciated...

share|improve this question

2 Answers 2

Have you installed the extension pack? With VirtualBox 4.0 and beyond you need to install a pack to get the functionality you are expecting. The VirtualBox 4.1.4 Oracle VM VirtualBox Extension Pack is what you need

Support for USB 2.0 devices, VirtualBox RDP and PXE boot for Intel cards.

Grab it here:

https://www.virtualbox.org/wiki/Downloads

share|improve this answer
    
I've installed the extension pack - pretty sure. But I'll check it out again, and let you know tomorrow. tnx. –  Rupal Oct 13 '11 at 13:06
    
I can confirm that it is there (guest additions). And checked box for remote display in settings. –  Rupal Oct 14 '11 at 6:49
1  
Do you have windows firewall ( or another ) enabled that is blocking connections to 127.0.0.2? –  haXs Oct 14 '11 at 10:02

If you have the proper extensions, then it should work.

You should take into account the network setup you used for the VM. If the network interface of the guest machine is in a bridge mode, then the ip is of the same network as your host OS. If you used NAT (this is default), then the guest network interface has an ip in the range of 10.xxx.xxx.xxx and your host machine has an ip from the same subnet. If you are going to use remote desktop to connect to the VM, I suggest you shut down the vM, go to settings and change the network interface to be bridged. Turn on the VM, and the ip of the VM should be in the same subnet as your host ip address. This will make it easier to remote desktop to your VM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.