Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

System OS: Fedora 13
Web Server: Apache (already installed)

Tried the following commands to no avail while trying to upgrade Apache 2.2.17:

  • yum upgrade
  • yum update
  • yum check-upgrade
  • yum update httpd
  • yum install httpd

After all these commands were tried I kept receiving a message stating that there aren't any packages / updates available and that the latest version was already installed.

rpm -qa | grep -i httpd shows httpd 2.2.17

share|improve this question
add comment

migrated from stackoverflow.com Oct 12 '11 at 14:19

This question came from our site for professional and enthusiast programmers.

3 Answers

Maybe your mirror is old or out of date? Try 'yum clean all' and then do another update attempt. If all else fails, you could fetch the RPM manually and install it that way.

share|improve this answer
add comment

Well 2.2.17 is the most recent version available in the Fedora 13 repositories so yum is quite correct. You can't upgrade if you already have the most recent version.

If you want to upgrade beyond 2.2.17 you will have to upgrade to Fedora 15, which has version 2.2.19 of apache available, or else build apache from source or find somebody that has built rpms of newer versions.

share|improve this answer
add comment

Fedora 13 is EOL.

Here is the release life cycle:

http://fedoraproject.org/wiki/LifeCycle

So to get the latest version Apache, you will need to upgrade to the current version of Fedora.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.