Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've setup a new Dell Poweredge R410 server with debian squeeze. If the server is idle for a longer time it seems to go to sleep mode. If I ping the server, it doesn't answer for 10-20 seconds and then comes up again. In in /var/log/messages I can see:

Oct 13 12:54:56 localhost kernel: [74420.949520] device eth0 entered promiscuous mode
Oct 13 12:55:49 localhost kernel: [74473.200155] device eth0 left promiscuous mode

There is nothing configured in /etc/acpi that the server should go to sleep mode if there is no activity for a longer time.

Does anyone know what else can cause the issue?

share|improve this question
    
Could you please post a log snippet? –  quanta Oct 12 '11 at 16:03
    
I updated the question with the last log messages from /var/log/messages –  markus Oct 13 '11 at 13:12
    
Promiscuous mode is what happens when you run tools like wireshark to sniff all network traffic; it has nothing to do with sleeping. –  psusi Oct 13 '11 at 15:13
    
Yes you're right. For further debugging I run tshark on that server. That problem appered arround that time, but no log messages to see. –  markus Oct 13 '11 at 15:18
    
Do you see something with dmesg? –  ott-- Oct 14 '11 at 16:59

1 Answer 1

up vote 0 down vote accepted

The problem was caused by the bnx2 network driver. After upgrading from version 2.0.2 to 2.0.23b the problem is solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.