Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is probably an easy question, but I've been at it for days with no luck. I need soap enabled to run an application on linux CentOS/Apache. I have PHP installed and have loaded soap.so in /usr/lib/php/modules/. I also have edited php.ini to point to the correct extensions directory. After restarting apache though, the recognized modules simply do not change in phpinfo();. I am baffled. Any help is greatly appreciated.

share|improve this question
    
How did you install soap extension? What is the output of php -i | grep soap? –  quanta Oct 12 '11 at 16:46
    
I unpacked a php tarball with soap enabled in /home/ and copied the module into the php modules directory. Running that command gives me: Failed loading /usr/lib/php/modules/ioncube_loader_lin_5.3.so: cannot open shared object file: No such file or directory –  Jay Oct 12 '11 at 17:00
    
I only did so because yum install gave some sort of versioning error. –  Jay Oct 12 '11 at 17:22
    
Can Apache read that file? –  sinping Oct 12 '11 at 19:12
add comment

2 Answers

You will want to edit your php.ini to remove ioncube_loader_lin_5.3.so. Then try reloading php. SOAP generally comes with PHP 5 as a standard installed module. Unless the user has specifically recompiled PHP to remove it.

share|improve this answer
add comment

I agree with Thomas, you should use the default SOAP library enabled with PHP 5. However, you may have overwritten it when trying to install the initial SOAP lib. Also, take a look at php.ini for the section labeled [soap].

Then make sure you have this file in /etc/php.d/:

$more soap.ini

;Enable soap extension module

extension=soap.so

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.