Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to connect to an Alfresco server, via Webdav, from a Windows 7 client. I can create a web folder connection with the wizard, but there are three or more folder links created and none of them work, double clicking on them simply does nothing. One of the folders have the name that I specify in the wizard, the others are simply named as the server adress.

While surfing the net I've seen that others have experienced the same issue, but so far I haven't seen any solution or any explanation.

Edit: I might add that the client is running Windows 7 RC, build 7100.

share|improve this question
    
what client is it that you are using? –  djangofan Nov 13 '09 at 19:55

3 Answers 3

I found this which might be the source of your problem:

http://support.microsoft.com/kb/841215

It talks about Sharepoint, but as I understand it, SharePoint exposes a WebDAV service. The issue is that Vista (and presumably Windows 7) don't support WebDAV using HTTP Basic Authentication.

Try changing to Digest authentication, or use one of the standalone WebDAV clients. If you must access the folder using Windows Explorer, try the regedit hack for Vista (the key is still present in my Win 7 RC installation)

share|improve this answer
4  
This fixed my problem trying to map a network drive to a WebDAV server in Windows 7. For those who don't want to read the whole article: You can enable Basic authentication on Windows Vista/7 by going to the registry key HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters and setting the DWORD value "BasicAuthLevel" to 2, then reboot. –  Kristopher Johnson Dec 8 '11 at 17:42
    
In addition to this it is important to enable the webclient service. On some windows 7 systems (all on ours), I discovered that they were disabled by default. Without this one would still be banging one's head against the wall like I did for 7 hours until I discovered this. –  Dark Star1 Apr 25 at 8:21

Have a look at the Web Folder Client's issues list. There is one called "anchor-click-behaviour-max-length". Maybe that's what you hit.

share|improve this answer

If you dont have Sharepoint or Alfresco, you might get additional information on your problem by testing with a different WebDAV server. As a suggestion, you can also use NULL FTP Server, which is also a FTP WebDav server .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.