Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've tried to use mod_perl in apache that comes with Mac OS X 10.6. To do that I add the following line in /private/etc/apache2/httpd.conf:

LoadModule perl_module        libexec/apache2/mod_perl.so

But when I try to execute a perl script I have an error:

You don't have permission to access /~user1/mod_perl_rules1.pl on this server.

Inside of /var/log/apache2/error_log I found a mod_perl error:

[Mon Oct 03 01:04:09 2011] [error] [client 127.0.0.1] Options ExecCGI is off in this directory: /Users/user1/Sites/mod_perl_rules1.pl
share|improve this question

migrated from apple.stackexchange.com Oct 13 '11 at 0:28

This question came from our site for power users of Apple hardware and software.

add comment

2 Answers

You need to put this in your conf:

<Directory "/Users/user1/Sites">
Options FollowSymLinks
Options +ExecCGI
AllowOverride None
</Directory>
share|improve this answer
add comment

As it said, you need to turn on the ExecCGI option in this directory, something like this:

<Directory "/Users/user1/Sites">
   Options +ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.