Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A few months ago we upgrade our DCs from 2008 to 2008 R2.

Two weeks ago I saw that I didn't copy the new admx/adml files to the central store.

Because I want to use the new policies, I copied all local files from one of the DC's %windir%\PolicyDefinitions to the central store.

Today I opened rsop.msc on one of the member servers and got a "parsing error":

**ADML**
Administrative Templates
Encountered an error while parsing.
Expected one of the Following possible element(s), < text >,
< decimalTextBox >, < textBox >, < checkBox >, < comboBox >,
< dropdownList >, < listBox >, but Found < multiTextBox > instead.
File
\\contoso.com\sysvol\contoso. . . TerminalServer-Server.adml, line 198, column 60

**ADMX**
Administrative Templates
Encountered an error while parsing.
Encountered an unknown error while parsing (error = 0x87400001): -2025848831 (0x87400001)
File
\\contoso.com\sysvol\conto. . . \Terminalserver-Server.admx, line 9, column 41

After restore of the old admx/adml it worked without problems.
Any ideas, whats wrong with the new admx/adml Templates?

Update 16.01.2012
Could it be possible that the old "2008 SP2" Terminal Servers cannot work with the new (Remote Desktop Services) policies implemented with "2008 R2"?

share|improve this question

1 Answer 1

See http://blogs.technet.com/b/askds/archive/2009/12/09/windows-7-windows-server-2008-r2-and-the-group-policy-central-store.aspx as it explains the reason. Was the member server Windows Server 2008?

share|improve this answer
    
thanks for the down vote. can I suggest a comment to go with it the next time explaining why? The link explains the cause is compatibility issues in the templates with Vista/2008. –  maweeras Oct 23 '11 at 9:17
    
No, our DCs was running on 2008 R2 before we copied the new policy files to the central store. The Windows 7 SP1 Management Workstation has the new RSAT installed. –  Psymon Jan 16 '12 at 9:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.