Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows Server 2008 R2 machine that is connected to our LAN. We inherited this machine, meaning that we didn't set it up ourselves and may not be aware of everything about it. However we know that W2k8 is installed as a VMware guest.
This machine doesn't have a video card and doesn't allow to plug a keyboard or a mouse, additionally its USB ports have been disabled, it is thus a headless server (of course, it has a CD/DVD reader.) All this means that we always connect via the Ethernet port (using Remote Desktop Connection.)

We mistakenly set Network Discovery to off, and since then this machine appears to be unreachable. Indeed it doesn't allow RDC anymore and the only thing we can manage to do successfully is to ping it. Note that this machine is not a domain controller, it's just part of 'Workgroup'. Obviously its name doesn't appear anymore if we do a network scan, but, as I said, we can ping it.

We have tried three things so far to reestablish some form of control over that machine:

  1. Microsoft Management Console (MMC) snap-ins
    This initially was producing a RPC server is unavailable error message. After a while this turned into access denied.
    My guess here is that turning Network Discovery to off disabled some key services required to make the snap-in to work. And, after a while, perhaps our attempts started to be perceived by the firewall as attacks, that could be why the error message changed into 'access denied'.

  2. PsTools
    Basically giving the same results as above. First getting the complaints about the RPC server being unavailable and then the 'access denied' one.

  3. Push VNC
    I had never used Push VNC before so I'm not too sure what should be the expected output when all goes well. But it just doesn't seem to "push" it... Anyway, maybe it wasn't even intended to push VNC on Windows Server 2008.

So here we are with this "remote server", in fact physically just next to us and reachable by hand, but with no way to get it to "talk" to us...

What steps could we take to get this machine back up and running on our LAN ?

share|improve this question
    
tried remote registry? or even remote access to services? –  BoyMars Oct 13 '11 at 10:23
    
boot the drive in another machine in safemode and reenable it? I think all the standard tools use RPC so if you've blocked that and have no other 3rd party tools on there you might be out of luck. Being headless is there any management console on the network interface that you could see if you boot in a CLI mode? –  JamesRyan Oct 13 '11 at 11:22
    
Have you tried connecting by IP address? –  John Gardeniers Oct 13 '11 at 11:28
    
@BoyMars Remote registry produces the same sort of reponse: access denied. –  dindeman Oct 13 '11 at 12:16
    
@JamesRyan Well, of course I'm very tempted to go down that path and I'm happy that you mention it. I was just worried about somehow harming the drive's data by booting it in another hardware environment. Do you think it's ok to try that ? Maybe it doesn't matter at all but remember that it's a Win 2008 set up as a VMWare host. –  dindeman Oct 13 '11 at 12:27
show 6 more comments

1 Answer

up vote 4 down vote accepted

Turning off Network Discovery doesn't disable TS/RDS and doesn't prohibit RPC communications, that I'm aware of. Network Discovery (by and large) is exactly what it sounds like; discovery. Not accessibility or communication but simply discovery. You can generally turn Network Discovery off on any server with any role and still have the server function in that role. My guess is that the server is in a wonky state. I would reboot it and see if that resolves the problem.

How did you "inherit" this machine? Where did you "inherit" it from? What is it's purpose? This sounds like an unsustainable situation. You have a server but don't have full controll of it's hardware and software resources, that's not something I'd allow on my network.

Here's a rundown of Network Discovery with some detail:

http://blogs.technet.com/b/networking/archive/2010/12/06/disabling-network-discovery-network-resources.aspx

share|improve this answer
4  
Wonky - word of the day –  squillman Oct 13 '11 at 11:39
    
I've been waiting to use that all week. :) –  joeqwerty Oct 13 '11 at 11:57
    
Ok this is very interesting, I have been scratching my head since it happened about the incredible consequences of turning Network Discovery to off... and your comment somehow relieves me (altho it doesn't solve my problem yet.) I can only tell you that it is really the only thing that was (mistakenly) done, and as soon as the button got clicked we lost the RDC and the problems started. Please allow me come back to you on the rest of your post later on. I will definitely have a look at the link you provided. Thanks! (annoyingly I need to run out now, sorry.) –  dindeman Oct 13 '11 at 12:37
1  
on 2008/win7 turning off network discovery blocks a bunch of things at the firewall (including rpc) in both directions –  JamesRyan Oct 13 '11 at 14:57
    
This is hardly scientific, but in WFAS on a W2K8 server I counted 62 rules blocking inbound traffic with Network discovery on and 62 with it off. I counted 34 rules blocking outbound traffic with Network Discovery on and 22 with it off. It looks to me like WFAS blocks outbound but not inbound traffic based on the state of Network Discovery, which makes sense as Network Discovery is intended to enable or disable the discovery of shared resources to and from the host, not block access to shared resources to and from the host. –  joeqwerty Oct 13 '11 at 15:50
show 21 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.