Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows Server 2003 that acts as the file server. I have moved a lot of files from a backup (different domain) to the new shares.

The strange thing is that people can open the files, but they can't save over it. Then it asks for a new filename (no overwrite).

I have tried to take ownership as administrator, and removing the read-only (gray) checkbox from the folder (incl. subfolders and files).

Someone knows what to do?

share|improve this question
add comment

1 Answer

This sounds like your NTFS ACLs are incorrect. What I would do (which may work for you or may not, I'm not guaranteeing anything) would be this:

  • Edit the properties for the folder containing the files, and set the permissions to what I want them to be
  • Go into the Advanced section, and tick the "Replace permissions on child items" box Click OK and wait while the permissions are updated

This will reset the permissions on everything inside the parent folder to be whatever the parent folder is. This answer does assume you know about NTFS permissions, if not then I would suggest reading up on them first so that you're comfortable with the concept.

share|improve this answer
    
I tried that. But it failed. Now I did the following and it works.. Properties of the folder holding the files, security tab, advance settings, uncheck the Allow inhereritable permissions, apply. And then do the thing you described above, then check the Allow inhereritable permissions again.... very.. very.. strange... –  Sven Oct 13 '11 at 13:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.