Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a web service running under IIS 6.0 on a Windows Server 2003 R2 machine. One of the web service calls returns a very large dataset (10 mb). When the client application receives this it gets the first 100 kb or so instantly then transfer slows to around 5-6 kb/s. I tried tweaking every setting I could find and nothing helped.

Next I set up filezilla on the same server and had it server a 10 mb pdf. Downloading this pdf to the same client machine exhibits the same behavior, first 100 or so kb comes through at 500 kb/s then it drops to 5-6 kbs for the rest.

From there I've now tried tweaking various registry settings such as the tcpack one but nothing is helping it. The machine has no load on it, these test requests I'm making are the only requests. I'm on the same LAN as this machine, the ping is essentially 0 as it is just a simple router between my client and this server. This same client hooked up to a windows 2008 server running IIS 7 gets the entire 10 mb file in about 3 seconds -- unfortunately I can't tell all of our customers to upgrade to IIS 7/win 2008 :)

Any suggestions on where to look or what to try next? I see a lot of similar questions but none seem to provide an answer for this case, I mean this is a serious application server on an enterprise LAN transferring files at 5kbs something very basic must be wrong here right?

--- I can't answer my own question for a few hours yet but this is the answer:

Coding Gorilla's answer led me to start looking at the NIC settings, it was at this point that I realized this is a XEN virtual server with an emulated NIC (I'm just a programmer trying to get this server running so I had assumed it was a real server).

A few quick searches later led me to this kb article: http://support.microsoft.com/kb/888750

I used method 2, rebooted and now everything is running full speed again. Hopefully this will help others.

share|improve this question
    
Can you reproduce the behavior from multiple client machines? Is this on from a LAN connection or across the internet? –  Coding Gorilla Oct 13 '11 at 13:57
    
Yeah we can see it from all of our clients, I had a few other guys on the team try downloading the ftp file from their house and its just as slow. So I've seen the issue on the same LAN as the server and also across the internet at various peoples homes. Its so strange because for some people it will serve at full speed for 10-15 seconds before dropping to 5kbs, but it always drops. –  Kishok Oct 13 '11 at 14:04
    
I'd investigate the possibility of an Ethernet duplex mismatch. If you can't lock the duplex on both sides, don't lock it on just one! –  David Schwartz Oct 13 '11 at 14:07

1 Answer 1

Given that you see this behavior on LAN and WAN, I would check the NIC on the server, if the server has alternate NIC (ports) I would try switching to one of those other ports, if it has an actual card, then I would try swapping it out. Also check the manufacturer's website (server and NIC) to see if there are updated drivers. If that doesn't work, then I would look at the switch or hub the server is connected to.

That's where I would start anyway; those might not be the final causes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.