Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Are there packages for RHEL and distros based on it (CentOS, Scientific Linux, etc.) that contain the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files so that higher levels of encryption can be supported in Java? I know that you can currently download these files from Oracle, but it would be nice if there was a package for them for Java 6/7.

share|improve this question
    
add comment

1 Answer

up vote 2 down vote accepted

You can use Bouncy Castle instead:

Name       : bouncycastle
Arch       : noarch
Version    : 1.46
Release    : 1.el6
Size       : 2.3 M
Repo       : epel
Summary    : Bouncy Castle Crypto Package for Java
URL        : http://www.bouncycastle.org/
License    : MIT
Description: The Bouncy Castle Crypto package is a Java implementation of cryptographic
           : algorithms. The package is organised so that it contains a light-weight API
           : suitable for use in any environment (including the newly released J2ME) with
           : the additional infrastructure to conform the algorithms to the JCE framework.
share|improve this answer
    
Thanks! That works if you use the Bouncy Castle API, but according to the Bouncy Castle site, if you are trying to use Bouncy Castle as the JCE security provider, "with JDK 1.4 and later you will need to have installed the unrestricted policy files to take full advantage of the provider. If you do not install the policy files you are likely to get something like the following: java.lang.SecurityException: Unsupported keysize or algorithm parameters at javax.crypto.Cipher.init(DashoA6275)". –  Gary S. Weaver Oct 17 '11 at 15:59
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.