Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a linked server from a 2005 instance to a 2000 instance that I am getting an error when trying to do an Update accross the linked server. This Update has worked for the past 2 years without issue. The last 2 days it is now failing with this error

OLE DB provider "SQLNCLI" for linked server "sr1ap004" returned message "Multiple-step OLE DB operation generated errors. Check each OLE DB status value, if available. No work was done.". Msg 16955, Level 16, State 2, Line 1 Could not create an acceptable cursor.

I have verified permissions with the linking account, I can run simple select without issue. I have also tried to recreate the linked server, and verified that RPC and RPC out are both set to 'true'

Thanks for your help!

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.