Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are having a problem when we moved a Windows Server 2008 R2 machine from one switch to another (moved the patch cable) is not recognizing its connection as a domain connection but instead as a public connection.

We did not change anything in the network configuration.

Is there a way to force the machine to recognize the new switch (we are assuming the switch change is at issue) as its new Domain connection? Or is it an unknown configuration problem?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

There migh be an error in the communication from this new switch to the Domain Controller.

The icon of public or domain network is managed by the Network Location Awareness (NLA) service.

To detect if you are in your domain the NLA service do this two things:

  1. Check if the network dns suffix on that network is the same of the value storage in the registry key HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Group Policy\History\NetworkName. If not it wont be marked as Domain. Check your DNS suffix.
  2. If the suffix is the same of the value, the computer will try to contact the domain controller using LDAP. If this is success you will have a Domain profile. To check this install the telnet client and run: telnet *Name-Of-Domain-Controller* 389
  3. Check if the port UDP 389 is open between the server and the DC.
share|improve this answer
1  
The SRV records used for locating GC servers could be mucked up too –  SpacemanSpiff Jan 28 '12 at 16:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.