Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using sendmail to send mail from my Rails application. But, there seems to be a error happening while sending mails to a specific user domain. The error from /var/mail/* is as follows:

Date: Tue, 11 Oct 2011 16:33:46 GMT
From: Mail Delivery Subsystem <MAILER-DAEMON@*****>
Message-Id: <201110111633.p9BGXkpR010310@******>
To: <****@*****>
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
Subject: Returned mail: see transcript for details
Auto-Submitted: auto-generated (failure)
This is a MIME-encapsulated message


The original message was received at Tue, 11 Oct 2011 16:33:42 GMT
from localhost []

   ----- The following addresses had permanent fatal errors -----
    (reason: 573 ********@****** failed to route the address)
    (reason: 573 *******@****** failed to route the address)
    (reason: 573 *******@******* failed to route the address)

   ----- Transcript of session follows -----
... while talking to *********.com.1.0001.arsmtp.com.:
>>> MAIL From:<*******@*******> SIZE=1273
<<< 573 ********@********* failed to route the address
554 5.0.0 Service unavailable

Content-Type: message/delivery-status

Reporting-MTA: dns; StreetSense
Received-From-MTA: DNS; localhost
Arrival-Date: Tue, 11 Oct 2011 16:33:42 GMT

Final-Recipient: RFC822; ****@*******.com
Action: failed
Status: 5.0.0
Diagnostic-Code: SMTP; 573 *******@******* failed to route the address
Last-Attempt-Date: Tue, 11 Oct 2011 16:33:46 GMT

Final-Recipient: RFC822; *******@********.com
Action: failed
Status: 5.0.0
Diagnostic-Code: SMTP; 573 *******@******** failed to route the address
Last-Attempt-Date: Tue, 11 Oct 2011 16:33:46 GMT

Final-Recipient: RFC822; ******@*********.com
Action: failed
Status: 5.0.0
Diagnostic-Code: SMTP; 573 *****@******** failed to route the address
Last-Attempt-Date: Tue, 11 Oct 2011 16:33:46 GMT

The bounced back emails are all from the same domain, and mails are being successfully sent to other domains. When I looked for SMTP 573 diagnostic codes, I got this "573 Internal server error, IP address related.". But I dont know what it means. Can anyone help me?

I ran these commands and I run it and got the following outputs:

# dig streetsense.com MX

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> xxxxx.com MX
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61139
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 4, ADDITIONAL: 4

;xxxxx.com.     IN  MX

xxxxx.com.  3600    IN  MX  10 xxxxx.com.1.0001.arsmtp.com.
xxxxxx.com. 3600    IN  MX  20 xxxxx.com.2.0001.arsmtp.com.

xxxxx.com.  155394  IN  NS  ns04.ntiva.net.
xxxxx.com.  155394  IN  NS  ns01.ntiva.net.
xxxxx.com.  155394  IN  NS  ns02.ntiva.net.
xxxxx.com.  155394  IN  NS  ns03.ntiva.net.

ns01.ntiva.net.     147 IN  A   xxx.xx.xx.xxx
ns02.ntiva.net.     147 IN  A   xxx.xx.xx.xxx
ns03.ntiva.net.     147 IN  A   xxx.xx.xx.xxx
ns04.ntiva.net.     147 IN  A   xxx.xx.xx.xxx

;; Query time: 45 msec
;; SERVER: xxx.xxx.x.x#xx(xxx.xxx.x.x)
;; WHEN: Tue Oct 11 18:08:23 2011
;; MSG SIZE  rcvd: 262

ping also seem to be working:

# ping xxxxxxx.com
PING xxxxxxxx.com (xxx.xx.xx.xx) xx(xx) bytes of data.
64 bytes from linux06.ntiva.com (xxx.xx.xx.xx): icmp_seq=1 ttl=53 time=29.0 ms
64 bytes from linux06.ntiva.com (xxx.xx.xx.xx): icmp_seq=2 ttl=53 time=27.4 ms
64 bytes from linux06.ntiva.com (xxx.xx.xx.xx): icmp_seq=3 ttl=53 time=27.4 ms
64 bytes from linux06.ntiva.com (xxx.xx.xx.xx): icmp_seq=4 ttl=53 time=27.4 ms

Can anyone help me to find the issue?

share|improve this question
Status 573 isn't listed in ietf.org/rfc/rfc5321.txt (the current SMTP definition): it is a vendor extensions. –  Richard Oct 17 '11 at 6:28

2 Answers 2

up vote 1 down vote accepted

It means the server encountered an error internally in it's processing that is somehow related to your IP address. Ping is irrelevant - as is what you ate for breakfast. Obviously - the message was not delivered to the server.

Could be a way to tell you to get lost (as in: IP address blacklisted for some reason). Could be a failure to do anything - that will be visible on some error log on the server. Not your problem unless you (a) suspect you are blacklisted or (b) are the server operator so you can check and fix.

share|improve this answer
Hi..the emails are not sent and the domain to which the mails are not send is the major customers of my site. This has been a major headache for me for the past week. And I have full access to the server –  rubyprince Oct 17 '11 at 7:00
Well, then start debugging it on the server. And the emails are sent - the recipient server just does not say "I got it", he says "sorry, internal error". Start on the server - any non totally stupid server will have an error log showing what is behind this error. –  TomTom Oct 17 '11 at 7:39
you mean I have to start debugging on the recipient server?.. –  rubyprince Oct 17 '11 at 8:52
Yes, This is a SMTP error that the recipuient server tells your sender. So, it is not the senders problem to debug it - the sender has no idea how to even do that. This needs to be done on the recipient server. –  TomTom Oct 17 '11 at 10:38
ohh..I understand..but the thing is these addresses are getting mails from other ids..for example, I am able to send mail and they are receiving it when I send mail from my gmail account. They are not receiving the mail only in the case from my server. –  rubyprince Oct 17 '11 at 11:26

Any 5xx-errors in SMTP means Permanent Delivery Error.

Here you have a triad of session-parameters, which can correlate with result

  • From address (e-mail)
  • To address (e-mail)
  • sender IP (your server IP) or hostname

You have to check all possible variants, changing only one parameter from session to session (gmail test I'll not accept, bc you change both from name and server) and analyze answers

During test we'll identify - is it your ban or misconfiguration of ***.com.1.0001.arsmtp.com (both cases are possible)

share|improve this answer
I have changed the to address to my gmail address and the server is sending mail without any problems..also I have tried changing my hostname and still the same error appears with the change in hostname...I have not tried changing the from address..will try that and update you.. –  rubyprince Oct 17 '11 at 13:50
for TO change you'll have to save old recipient domain (in order to have session with the same host as before)... Sory, forgot to mention obvious for me detail –  Lazy Badger Oct 17 '11 at 14:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.