Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

To start, we have a non-best-practices Exchange setup. Rather than a front-end RPC proxy server and a back-end mailbox server, we have a single server that is a DC/GC/Exchange. Setting up RPC-over-HTTP only appears to work on Outlook 2007 clients, which is wierd because it's an Exchange 2003 server (or perhaps I set up that Outlook installation when it was connected to the domain and forgot that I did, so that's why it's working).

The problem occurs during Outlook configuration when you type the person's username and click "Check Name". An error box comes up saying that the connection to Exchange is unavailable, and the name won't get underlined. I've checked and double-checked the configuration (this is one of the best guides I've found), and everything is set up correctly, with the exception of two possible caveats which I'm about to detail...

1: All of our DCs are GCs also, but the only one with the RPC proxy component installed is the one that has Exchange on it. This is the only server that Outlook clients are supposed to reference, but the setup guide specifies that all(?) GCs need to have the RPC proxy component.

2: I ran a test using testexchangeconnectivity.com, and it fails when trying to ping port 6001. From what I understand, the only port required for Outlook Anywhere is 80/443. Because of our non-standard setup, do I also need to open ports 6001, 6002, and 6004 to the Internet? Are there any other ports that I need to consider?

Any help is appreciated!

Update: I experimented by opening port 6001 to the Internet on our firewall. I confirmed it was successful by telnetting in, but testexchangeconnectivity.com STILL reports RPC endpoint 6001 as unresponsive. That seems to indicate to me that the server is having trouble proxying to itself... I also installed the RPC proxy component on the other two DCs on our LAN (there are other GCs at other WAN sites, but I didn't modify those yet), but that doesn't appear to have made a difference. Help!!

share|improve this question

2 Answers 2

All you need to have open in the firewall is 80/443 for clients to connect. Port 6001 is back end and is essentially the server checking with itself.

Make sure the registry entry in the following link under "Procedure" is properly configured. That will likely solve your issue

http://technet.microsoft.com/en-us/library/aa998910(EXCHG.65).aspx

share|improve this answer
up vote 0 down vote accepted

After reading through the TechNet articles over and over, something dawned on me... How could the server not proxy to itself? Because it was using the wrong name!

My ValidPorts registry key had the correct ports set up for "mailserver" and "mailserver.domain.local", but the server is accessed over the Internet via "mailserver.domain.com". I added the respective entries for that domain name, and voila! It works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.