Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am installing Scientific Linux 6.1 via kickstart, and I am trying to debug a problem.

According to Tips and tricks for anaconda and kickstart, I should have several virtual consoles available:

What the different terminals display

Alt-F1    The installation dialog when using text or cmdline
Alt-F2    A shell prompt
Alt-F3    The install log displaying messages from install program
Alt-F4    The system log displaying messages from kernel, etc.
Alt-F5    All other messages
Alt-F7    The installation dialog when using the graphical installer

The Virtual Consoles Alt-F1, F3, F4 & F5 all work and show various logging information. However, the Virtual Console at Alt-F2 does not do anything.

I could really use access to the shell prompt (Alt-F2), however there is no Shell prompt available at the second virtual console (Alt-F2). All I have is a blinking '_'.

Can I forge Alt-F2 to show me a shell prompt?

share|improve this question

2 Answers 2

I have just tested an automated kickstart install (driven by cobbler) and it works fine for me. All I had to do is press Ctrl+Alt+F2 (virt-manager has a menu for this). The only problem is that the shell is not avaialble right away, you have to wait for the installer to reach a certain stage.

Regarding debugging, you might find the Anaconda logging page helpful.

share|improve this answer
    
Do you happen to know the line which cobbler passes to the kernel? I am not using cobbler, but suspect that's my problem. –  Stefan Lasiewski Oct 18 '11 at 1:04
    
It's actually koan that starts the virtual machine, but here it is: method=nfs:myserver:/Scientific-6.1-i386-DVD/ ks=http://myserver/cblr/svc/op/ks/system/myvm ksdevice=link kssendmac lang= text –  Cristian Ciupitu Oct 18 '11 at 1:32
    
Are you installing Enterprise Linux version 5.7 (or similar) or version 6.x? –  Stefan Lasiewski Oct 18 '11 at 4:23
    
I've tested with Scientific Linux 6.1, the distribution mentioned in your question. –  Cristian Ciupitu Oct 18 '11 at 6:17

Look into /etc/inittab. Maybe the entry for tty2 is disabled. If you want a login prompt, put this line into it:

2:2345:respawn:/sbin/getty 38400 tty2

For an autokgin as root, use:

2:2345:respawn:/sbin/mingetty --autologin root --noclear tty2

After editing, make init re-read this config:

telinit q

You should see something on tty2 now.

share|improve this answer
    
This is an installer, not an installed system. –  Cristian Ciupitu Oct 18 '11 at 0:47
    
Unfortunately I cannot access a commandline to view those files. And as a sidenote, RHEL6 has replaced /etc/inittab with Upstart (/etc/inittab is ignored). –  Stefan Lasiewski Oct 18 '11 at 0:53
    
@StefanLasiewski: Ok, the blank tty2 means that installation hasn't progressed so far that other vt's could be opened. What's in your ks.cfg? Any idea at what stage it fails? –  ott-- Oct 18 '11 at 1:09
    
@ott : I should clarify. The other Virtual Terminals (Alt-F1, F3, etc.) are working. Alt-F2 is the only VT which is not working. I updated my question to be more clear. –  Stefan Lasiewski Oct 18 '11 at 4:22
    
@StefanLasiewski: Yes, the installation stops before it can start a shell on vt2, that's why you see nothing. I think you can't make "normal" screenshots, but could you take pictures of tty3 and tty4 to see the last steps? –  ott-- Oct 18 '11 at 12:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.