Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have successfully configured an Apache2 webserver on one of my computers. Local access through HTTPS is working (https://localhost).

However, I cannot convince my router (a USR 9108) to allow traffic. I have tried pretty much any option that allows me to redirect / allow traffic (Virtual Server, IP Inbound Filtering, DMZ), but nothing seems to work in order to allow access to my HTTPS server through (I know my ISP doesn't block port 443 for a fact). Neither iptables seems to block any traffic.

Am I missing something? Any suggestions? Thanks in advance!

share|improve this question

3 Answers 3

You need to set up a virtual server to allow the traffic to be NAT'd to your web server.

A quick tutorial can be found here.

share|improve this answer
    
As I mentioned, I've tried pretty much everything on the router, setting up a virtual server was the first thing i tried. Sorry if I wasn't clear enough. –  alkar Oct 18 '11 at 18:12

Did you check that your webserver is really listening on your external interface? If it is only configured for localhost (127.0.0.1) you can't send out anything. In Unix do a netstat -an|grep LISTEN.

share|improve this answer
    
yes it does, I have checked that as well –  alkar Oct 19 '11 at 14:47
up vote 0 down vote accepted

The problem was fixed, with a little bit of luck, a little bit of trying everything related and some moderate amount of of insight.

You need to have the appropriate entry in the hosts file for Apache to receive the https request, since the server is behind a router (or at least, that's what how I understand it).

I'm shocked I didn't find a single mention about it while googling for the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.