Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In windows Vista, when I run certain programs, Vista says:

The publisher cannot be verified, are you sure you want to run this software?

I believe this applies to software which has not been signed, but I'm not sure.
My question is: how can I prevent this message from coming up for a specific program?
Is there a way I can tell Vista to "trust" a program from now on?

Any help or explanation gratefully received.

I'm running Home Premium.

share|improve this question

3 Answers 3

All software (EXE's, DLL's) should be signed for Windows Vista. It's required to get an application "Certified for Vista" and really just "good practice" overall.

You'll most commonly see the prompt when running applications that haven't been installed, applications you've downloaded, etc.

If you really want to "trust" a program that is on your system, without creating a security hole for other applications, then the easiest way would be to get your own digital signature and sign the application yourself (using signtool.exe) while also adding that certificate into windows certificate store. You don't need to purchase, a self signed certificate would be fine as long as it's in your Windows Certificate Store.

share|improve this answer
    
Is this technology unique to Vista? For example, does Windows 7 have the same behavior? (I did a quick search, but did not see anything). –  benc Mar 10 '11 at 21:42
    
I believe the technology was introduced with Windows 2000 –  saschabeaumont Mar 15 '11 at 1:23

This message is because the vendor has not certified the software with vista. Ticking the box that says don't ask again doesn't usually work. To get it to remember your choice you need to locate the exe file for the program, go to properties and under the general tab is usually a message that vista is blocking the program, unblock it and that should sort it. It will ask for UAC permission.

share|improve this answer
    
Thanks for that. Sounds very good, but when I click "UnBlock", then "OK", it makes no difference (even logged on as admin), and when I go back to properties, it still says it's blocking the program. Any suggestions? Thanks! –  AJ. May 3 '09 at 13:39

You get this for programs with no digital signature. To get rid of it, bug the developers to sign their software.

I don't know of you can disable it for individual files, but this will disable it for all .exe files:

Run gpedit.mscn using Start>Run. Then User Configuration>Administrative Templates>Windows Components>Attachment Manager. Then add '*.exe' to "Inclusion list for moderate risk file types"

Not really recommended.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.