Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Cyrus with SASL for authentication. I'm struggling getting logins to work properly though. I'm trying to setup virtual hosting, as we'll have several domains worth of email on this host.

In my imapd.conf:

sasl_pwcheck_method: auxprop
virtdomains: true
defaultdomain: fqdn.example.com

From sasldblistusers2:

matt@fqdn.example.com: userPassword

I have a mailbox called user.matt, and I tried creating user.matt@fqdn.example.com and I got an error saying the mailbox already exists. With this setup, I am able to login using imtest localhost -m DIGEST-MD5 -a matt, however I am unable to using imtest localhost -m DIGEST-MD5 -a matt@fqdn.example.com. There is also not a UNIX user called matt on the system. Does anyone have any idea what I am missing?

Exact error from syslog:

imap[23310]: badlogin: localhost [127.0.0.1] DIGEST-MD5 [SASL(-13): user not found: no secret in database]

share|improve this question
    
Did you already read the logs? –  Janne Pikkarainen Oct 19 '11 at 8:39
    
@JannePikkarainen: All the logs say is auth failed because imapd thinks the user doesn't exist. –  Matthew Scharley Oct 19 '11 at 9:03
    
Just got an idea, read my answer to you :) –  Janne Pikkarainen Oct 19 '11 at 9:13
add comment

1 Answer

up vote 1 down vote accepted

Do you have this in your imapd.conf?

loginrealms: fqdn.example.com

(imapd.conf man page tells you this):

   loginrealms: <empty string>
        The list of remote realms whose users may authenticate using cross-realm authentication identifiers.  Seperate each realm name by a space.  (A  cross-realm  iden‐
        tity is considered any identity returned by SASL with an "@" in it.) Note that to support multiple virtual domains on the same interface/IP, you need to list them
        all as loginreals.  If you don’t list them here, your users probably won’t be able to log in.
share|improve this answer
    
No I don't. Will try this tomorrow at work, but if this a real config variable, it'd definitely explain the problem. Will accept when I've tried it. –  Matthew Scharley Oct 19 '11 at 9:47
    
It is a real config variable. –  Janne Pikkarainen Oct 19 '11 at 10:19
    
Sorry, that first comment sounded horrible. Unfortunately, this doesn't seem to be helping. I've edited into the question the exact syslog that's being output. –  Matthew Scharley Oct 19 '11 at 21:56
    
Gah, I'm an idiot. At some point last night I deleted the user from SASLdb. This works perfectly, thanks a lot! –  Matthew Scharley Oct 19 '11 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.