Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Linux TFTP/PXE server which works.

If I setup failover on which is where TFTP is being served, the client fails with tftp open timeout.

I am testing with

tftp> binary
tftp> get /ltsp/i386/pxelinux.0

The failover I use is ucarp with creates a virtual IP address that it broadcasts.

When is a real IP, it works, when is a virtual IP then the clients can't access it.


Is there something special that have to be done when using ucarp and TFTP?


The the post have been updated as the original post had a DHCP server as suspect for the problem.

This is my ucarp part from /etc/network/interfaces. Ubuntu server

auto eth1
iface eth1 inet static
    ucarp-vid 3
    ucarp-password secret
    ucarp-advskew 10
    ucarp-advbase 1
    ucarp-master yes

iface eth1:ucarp inet static
share|improve this question
I'm pretty sure that this is independent of DHCP. Have you tried using a TFTP client against the virtual IP? – pauska Oct 19 '11 at 12:11
Great idea. You are right the DHCP server can be taken out of the equation. I'll update the post accordingly. – Sandra Oct 19 '11 at 13:24
First of all: You have 245.1 set as both the IP and the gateway.. that doesn't make any sense :-) Secondly, you say that "when is a virtual IP".. does that mean that you want .1 to be the virtual IP, or do you want .5 to be the virtual IP? Does TFTP against .5 work with the configuration you posted? – pauska Oct 19 '11 at 13:58
That's good point about the gateway =) Ideally would I like the gateway and TFTP to be the same address with failover. No this posted config sadly doesn't work with 245.5 from a tftp client. 245.1 works thought from the same tftp client. – Sandra Oct 19 '11 at 14:49
I understand - you want the ucarp to be the default gateway for your clients, but the ucarp boxes still need a different default gateway to get further. – pauska Oct 20 '11 at 11:34
up vote 1 down vote accepted

Found the problem.

For some unknown reason this firewall rule prevents ucarp from working.

# Generated by iptables-save v1.4.10 on Thu Oct  6 17:16:01 2011
:INPUT ACCEPT [22517:2222881]
:OUTPUT ACCEPT [16961:69145734]
# Completed on Thu Oct  6 17:16:01 2011
# Generated by iptables-save v1.4.10 on Thu Oct  6 17:16:01 2011
:INPUT ACCEPT [18:2668]
# Completed on Thu Oct  6 17:16:01 2011
share|improve this answer
That was my next suggestion, glad to see that you worked things out. – pauska Oct 20 '11 at 11:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.