Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have an SBS 2008 box which is running Exchange 2007 SP3 with Update Rollup 5. Everything works fine, apart from EWS. It used to work, but then it sort of stopped a few months ago and I can't for the life of me work out why.

Problem

We can't use OOF functionality in Outlook 2010 (which I believe polls the server API via EWS/Exchange.asmx), and other EWS capable devices, for example Mac OS X Lion does not work either.

I have investigated log files on the Exchange/SBS box and discovered that Exchange.asmx is throwing a 500 error, and we get instances like this:

2011-10-19 06:23:11 10.10.0.1 POST /EWS/Exchange.asmx - 443 - 10.10.2.14 Microsoft+Office/12.0+(Windows+NT+5.1;+Microsoft+Office+Outlook+12.0.4518;+Pro) 500 0 64 3

What I've done so far...

I've tried ExRCA at testexchangeconnectivity.com which always returns everything being fine, even EWS.

I've tried manually accessing EWS through a browser window - this seems to be OK as the server prompts for 401 authentication, and then on proper authentication with DOMAIN\user, I get the big XML dump of Services.wsdl definition.

I've tried setting all of the IIS virtual directory/folder authentication settings (e.g. Basic/Anonymous and so on) to the Microsoft recommended defaults on TechNet.

I have also tried running some various cmdlets in the Exchange shell to create the Web Services virtual directory etc but nothing works.

Can anyone help me with the next step in troubleshooting? Thank you for your time :)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Finally solved it. The solution for any Googlers who stumble upon this was to set SSL client certificates to "Ignore" under IIS - SBS Web Applications - EWS folder in the IIS management console.

I found this out from running the SBSBPA, of all things. So tip if you are struggling trying to diagnose this fault - run the BPA, it could find the problem for you! :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.