Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a business intelligence application called Qlikview that I am trying to install on a Windows Server 2003 SP2 64-bit machine. The application has several services that run, and they typically use ports 8081 - 8083. Usually what happens is when you start the services, you see the server listening on the ports in netstat. Ports 8082 & 8083 are working fine, but 8081 doesn't seem to want to listen. I've contacted the vendor and they have never experienced this issue before. There are no other applications trying to use the port so there are no conflicts. Is there something on the OS level that could prevent this port from being used? Any suggestions would be greatly appreciated.


share|improve this question

Is there another application, like a web based application that's bound to port 8081?

for instance, I use PRTG which runs on port 81 but port 81 is only active and listed in the netstat (running with no options) output when I'm running the web based management tool in PRTG.

Try running netstat -a -n -p tcp -b and look for port 8081 in the output.

share|improve this answer

McAfee sometimes uses this port. Here is one reference I could find now.

Are you sure,

netstat -anp tcp

shows nothing on tcp/8081?

share|improve this answer
McAfee is not installed, so there is no conflict there. – V W Jun 26 '09 at 16:54
Absolutely sure, netstat does not show anything for 8081. – V W Jun 26 '09 at 16:58

You've double-checked the "CommandCenterListenPort" value in the "C:\Program Files\QlikView\Publisher\CommandCenterService\QVPublisherCommandCenterService.exe.config" and seen that it's set to 8081? You might try setting that to another port just to see if it will listen on another port. If it doesn't listen when you try changing it to another port I'd say that something is up with the application.

(If you do change it to another port, you need to change the "CommandCenterURL" parameter in the "web.config" file in the ControlPanel folder the new port, too. Stop the "Publisher Services" before making these changes, and then restart them and ControlPanel should work, assuming that the server really does start listening on the new port.)

share|improve this answer
Someone who knows Qlikview! I've spent hours going through all that stuff with the vendor with no luck. I've tried using a different port but that won't listen either. I am also inclined to think that it is an application level issue as well, but if that was the case you'd expect the vendor to be able to fix it, right? – V W Jun 26 '09 at 17:32
Ugh... if you've already tried changing the port and it's still not listening then I think it's likely something up with the app. That sucks. I'd have to say that, at that point, I'd be going to the vendor... and if they can't fix it... sigh – Evan Anderson Jun 26 '09 at 17:44
Lol, ok, well thanks for taking the time to reply back. – V W Jun 26 '09 at 18:36
It's worth trying an uninstall/reinstall. It wouldn't be the first time I've seen an app mangled during the installation, with no error messages of course. – John Gardeniers Oct 8 '09 at 20:37

You mention that it has several services that listen on these ports. Just a thought, but is the service that is supposed to bind to port 8081 stopping for some reason? Or is it even really starting at all?

share|improve this answer

If it listens on the LAN but not via WAN ensure your ISP isn't blocking that port (try for a utility to test).

share|improve this answer

I'm surprised that no one's said this yet: Is there a firewall getting in the way? For instance, Windows Firewall?

share|improve this answer
That's what you're here for. What took you so long? ;) – joeqwerty Oct 23 '09 at 15:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.