Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed all the dev files (sudo apt-get install libmagick++-dev libmagickcore-dev libmagickwand-dev) as well as the gem itself (gem install rmagick), and everything installed just fine, no compilation or installation errors in either steps.

The problem occurs whenever I actually require 'rmagick':

ruby-1.9.2-p290 :001 > require 'rmagick'
LoadError: no such file to load -- rmagick
  from /home/marfay/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
  from /home/marfay/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
  from (irb):1
  from /home/marfay/.rvm/rubies/ruby-1.9.2-p290/bin/irb:16:in `<main>'

I have tried numerous ruby installs of different version on rvm, as well as system installs using aptitude, everything failed at require with the same error message.

Any guidance greatly appreciated!

share|improve this question
    
    
Didn't work, unfortunately. Still same problem. –  Mark F Oct 20 '11 at 2:10
add comment

1 Answer

up vote 4 down vote accepted

Try RMagick instead of rmagick:

$ irb
irb(main):001:0> require 'RMagick'
=> true
irb(main):003:0> puts Magick::Long_version
This is RMagick 2.13.1 ($Date: 2009/12/20 02:33:33 $) Copyright (C) 2009 by Timothy P. Hunter
Built with ImageMagick 6.6.8-5 2011-07-08 Q16 http://www.imagemagick.org
Built for ruby 1.8.7
Web page: http://rmagick.rubyforge.org
Email: rmagick@rubyforge.org
=> nil
irb(main):004:0>
share|improve this answer
1  
Wow...just wow... –  Mark F Oct 21 '11 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.