Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm attempting to do an Ubuntu 11.10 server install using a preseed file for the first time.

I created my preseed file by starting with the example file and just uncommenting/choosing what seemed reasonable. Here's the result, with no comments, for (relative) brevity. You can see the whole thing, comments and all, here.

d-i debian-installer/locale string en_US
d-i console-setup/ask_detect boolean false
d-i console-setup/layoutcode string us
d-i netcfg/choose_interface select auto
d-i netcfg/get_hostname string leeroy
d-i netcfg/get_domain string wharton.upenn.edu
d-i netcfg/wireless_wep string
d-i mirror/country string manual
d-i mirror/http/hostname string http.us.debian.org
d-i mirror/http/directory string /ubuntu
d-i mirror/http/proxy string
d-i mirror/suite string squeeze
d-i clock-setup/utc boolean false
d-i time/zone string US/Eastern
d-i clock-setup/ntp boolean true
d-i partman-auto/disk string /dev/sda1
d-i partman-auto/method string lvm
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-md/device_remove_md boolean true
d-i partman-lvm/confirm boolean true
d-i partman-auto-lvm/guided_size string max
d-i partman-auto/choose_recipe select home
d-i partman-partitioning/confirm_write_new_label boolean true
d-i partman/choose_partition select finish
d-i partman/confirm boolean true
d-i partman/confirm_nooverwrite boolean true
d-i partman/mount_style select traditional
d-i base-installer/kernel/image string linux-generic
d-i passwd/root-login boolean false
d-i passwd/user-fullname string Adam Tuttle
d-i passwd/username string jatuttle
d-i passwd/user-password-crypted password 8dbf2c32b5f2cd0670e53dc63e82da3f
d-i user-setup/allow-password-weak boolean true
d-i user-setup/encrypt-home boolean false
d-i apt-setup/services-select multiselect security
d-i apt-setup/security_host string security.ubuntu.com
d-i apt-setup/security_path string /ubuntu
tasksel tasksel/first multiselect standard
d-i pkgsel/include string openssh-server build-essential
d-i pkgsel/update-policy select none
d-i pkgsel/updatedb boolean true
d-i grub-installer/only_debian boolean true
d-i grub-installer/with_other_os boolean true
d-i finish-install/reboot_in_progress note
xserver-xorg xserver-xorg/autodetect_monitor boolean true
xserver-xorg xserver-xorg/config/monitor/selection-method \
       select medium
xserver-xorg xserver-xorg/config/monitor/mode-list \
       select 1024x768 @ 60 Hz

When I boot the installer with this preseed file, it runs fine until it chokes with this error:

VFS: Cannot open root device "(null)" or unknown-block(8,1)
Please append a correct "root=" boot option; here are the available partitions:
0b00 1048575 sr0 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)

I originally thought this might be because I had left the line d-i partman-auto/disk string /dev/hda commented out, and I've tried it with both /dev/hda,/dev/hda1, /dev/sda,/dev/sda1 (not sure which is correct), but I still get the same error each time.

What am I missing?

It's occurred to me that maybe I'm passing the wrong set of boot params to the installer. Before I make my changes, they start out as:

file=/cdrom/pressed/ubuntu-server.seed vga=788 initrd=install/initrd.gz quiet --

I've tried what feels like every possible combination of these existing parameters and the one I (am under the impression that I) need to add to use the preseed file. The only combination that seems to automate the installer is by deleting everything and using just this:

url=http://raw.github.com/gist/1301366/

Maybe the problem is that I need to include something here -- either something new or something from the original params, to setup the hard disk access? Any ideas?

share|improve this question
    
Do you get this error if you boot the installer without the preseed file? –  sciurus Oct 21 '11 at 19:24
    
Nope, I am able to leave the default boot options and run through the installer manually, and it works just fine. –  Adam Tuttle Oct 22 '11 at 11:44

1 Answer 1

d-i partman-auto/disk string /dev/sda1
should be
d-i partman-auto/disk string /dev/sda

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.