Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed IE 8 and I am now unable to authenticate with my SharePoint 2007 site using Integrated Authentication. I have no problems, however, connecting with Firefox using the exact same user account.

Thinking my problem might be related to IE 8 permissions, I added the site to the list of intranet sites. After this did not resolve the problem, I also reconfigured the security level to low for the intranet zone. I'm still unable to authenticate.

Interestingly enough, I'm able to connect to the Central Admin site using the same browser. Furthermore, as I previously mentioned, I have no problem connecting using Firefox. Both Central Admin and my development site are configured for Integrated Windows Authentication in IIS.

I've gone through the advanced settings in IE one-by-one and I haven't been able to figure out what's preventing me from authenticating with my SharePoint site using IE 8.

I thank you in advance for any information.

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

In the process of updating to IE8, is there any chance you were bitten by the loopback bug that's been frustrating so many of us? A relatively recent security update has been wreaking the sort of havoc you describe:

http://support.microsoft.com/kb/896861

This isn't going to affect sites running on high ports (e.g., your Central Admin site's default zone), but it will affect port 80 traffic looping back to the local machine.

The impact of this issue has been growing. In all cases I've encountered, setting the DisableLoopbackCheck DWORD (followed by a reboot) solves the problem.

Hope this helps!

share|improve this answer
    
That's it, exactly! I wasted so much time on that. Thank you very much. –  senfo Jun 27 '09 at 21:55
    
Happy to help. I spent so much time trying to figure the same problem out my first time around. It truly is maddening! –  Sean McDonough Jun 28 '09 at 2:42
    
OMG - thanks for this solution! I started losing it there for a sec. –  chickeninabiscuit Jul 1 '09 at 4:16
add comment

Make sure you have SharePoint 2007 SP2 installed, that is the only version that supports IE8.

share|improve this answer
add comment

Make sure IE8 Intranet mode is turned on. In addition I would check to see if "Enable Integrated Windows Authentication" is turned on under the advanced tab.

If you are able, I would also take a look at using Fiddler to verify what is being sent across the wire to the SharePoint site.

share|improve this answer
    
Thank you for the response. Both Intranet Mode and Integrated Windows Authentication are enabled. –  senfo Jun 26 '09 at 18:08
    
A few more Windows updates are being applied. As soon as they are completed, I'll check the Fiddler output. –  senfo Jun 26 '09 at 18:09
    
Are you going through a proxy server at all? –  Aaron Weiker Jun 26 '09 at 18:12
    
Unfortunately, no. There are no proxies configured. –  senfo Jun 26 '09 at 18:18
    
I reviewed the request headers and I definitely see the NTLM authorization going out: Authorization: NTLM TlRM............. –  senfo Jun 26 '09 at 18:22
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.