Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I set up a static ip for my linux box but DHCP still seems to run and changes my hostname and resolv.conf From what I understood just setting the iface to static should keep that from happening. I also did a "apt-get -y remove isc-dhcp-client dhcp3-client dhcpcd" but still no luck.

auto lo
iface lo inet loopback

auto eth0 eth0:1

iface eth0 inet static
 address 66.228.49.254
 netmask 255.255.255.0
 gateway 66.228.49.1

iface eth0:1 inet static
 address 192.168.169.183
 netmask 255.255.128.0

Ubuntu 11.04, Suggestions?

share|improve this question
    
Please post the output of ps wwaux|grep dhc|grep -v grep. –  Nils Oct 20 '11 at 21:12
    
root 2092 0.0 0.1 8428 556 ? Ss Oct19 0:00 /sbin/dhcpcd-bin -Y -N -H eth0 –  The Digital Ninja Oct 20 '11 at 21:22

2 Answers 2

You never actually killed dhcpd so it was still running.

All you needed to do was kill it.

share|improve this answer
up vote 0 down vote accepted

/etc/default/dhcpcd was set to write resolv.conf and set the host name. Changing both to "no" fixed the issue.

share|improve this answer
    
This and the running process are hints that you never disabled the dhcpcd-service in the runlevels. –  Nils Oct 21 '11 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.