Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to access an Intranet site from a client I get asked to login all the time. Then I get a 401.3 error. The site works fine locally on the server.

The site has its own app pool, Managed Pipeline Mode is Integrated. I have set Read/Execute, List and Read permissions on the root web directory for the IIS_IUSRS group. Identity impersonate is false. Anonymous and Windows Authentication are enabled.

Any ideas?

share|improve this question

migrated from stackoverflow.com Oct 20 '11 at 22:47

This question came from our site for professional and enthusiast programmers.

    
Update: I can access the site using the IP but not by name. Not sure what this means atm though. –  empo Oct 20 '11 at 11:20
    
Does it work if you give Everyone read/write/execute on the root level? –  Erix Oct 20 '11 at 12:21
    
No, I get 401.1 error, actually I'm getting that error all the time now instead of 401.3 –  empo Oct 20 '11 at 12:34
    
This needs to be moved to ServerFault. It's a configuration problem. –  Chris Lively Oct 20 '11 at 16:34
    
Update: If I change the App Pool Identity to NetworkService all is good. This could mean its a file system permissions issue. Though as explained earlier I have granted permissions to the app pool user account. –  empo Oct 21 '11 at 8:46

3 Answers 3

Make sure that anonymous identity is set to the proper user (one included in the IIS_IUSRS group). I would also try disabling windows authentication to see if the problem persists, I've had issues before on intranet webpages when it would prefer the windows authentication firsthand even with anonymous authentication enabled.

In case the client you are using to access the webpage has a valid domain user that is allowed to access the webpage, make sure the users password isn't expired.

share|improve this answer
    
The anonymous identity is set to IUSR. Disabling Windows authentication gives me a 401.3 error straight away. –  empo Oct 20 '11 at 10:53

Did you checked the permissions of directory? Since you using Windows authentication you need to makesure the accessing user has permission to the specific directory.

This may be help you Detecting permission issues using auditing and process monitor

share|improve this answer
    
Read my question again. Then change your answer. –  empo Oct 20 '11 at 10:31

Make sure you have the right default document set up. If IIS can't find the default document it falls back to directory browsing which you probably have disabled.

Also make sure you run:

aspnet_regiis.exe /i 

from your framework folder (usually c:\Windows\Microsoft.NET\Framework(64)\v4.0...

Also, download Fiddler and see what is going on on the wire.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.