Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a virtual machine with Windows Server 2003 (SP2). The DNS resolution seems to be broken, but the nslookup command works fine. Well, I guess that means that the DNS resolution works fine, but I get this response when I ping any domain:

Ping request could not find host FQDN. Please check the name and try again.

That brings all kinds of problems. The email server cannot send messages because it doesn't get the IP addresses for the domain names, etc.

The DNS servers work fine.

Any suggestions?

Thanks in advance.

ipconfig /all result

Configuración IP de Windows

   Nombre del host . . . . . . . : S15350948
   Sufijo DNS principal  . . . . :
   Tipo de nodo. . . . . . . . . : de igual a igual
   Enrutamiento habilitado . . . : No
   Proxy WINS habilitado . . . . : No

Adaptador Ethernet venet0:

   Sufijo conexión específica DNS:
   Descripción . . . . . . . . . : Parallels Virtual Network Adapter
   Dirección física. . . . . . . : 00-FF-7E-1C-68-10
   DHCP habilitado . . . . . . . : No
   Dirección IP. . . . . . . . . : xx.xx.xx.xx
   Máscara de subred . . . . . . :
   Puerta de enlace predet.. . . :
   Servidores DNS. . . . . . . . :

I tried OpenDNS and Google's Public DNS. I've already removed/reordered the DNS servers.

Ping request could not find host Please check the name and try again


Respuesta no autoritativa:
share|improve this question
What does ipconfig /all say ? – adaptr Oct 21 '11 at 9:20
How exactly do you run the ping and nslookup commands ? A sample would be nice. (Combined with the ipconfig /all output as adaptr asked.) – Tonny Oct 21 '11 at 10:08
@Tonny ping nslookup – Olav Gausaker Oct 21 '11 at 10:53
The only difference is that ping is using local dns cache, while nslookup performs direct ns query. Use ipconfig /flushdns to clear cache before trying again. – wqw Oct 21 '11 at 15:23

As far as I know when a program tries to connect somewhere it passes the domain name to the OS functions and OS uses its resolver library to do the lookup. On the other hand nslookup is doing lookups on its own.

I've seen something like that on my Win XP and it was probably caused by some new program, virtus or malware, because reverting to a week old Point of recovery solved the issue.

share|improve this answer

Is that the correct Default gateway? What is your networking mode in Parallels?

share|improve this answer
Just had the same "issue" today -- ping not "resolving". Turned out default gateway was incorrect. – wqw Oct 22 '11 at 14:03

I had similar problems. They were caused by a virus. Try running disk scan from Kaspersky or NOD32 live CD (you can download and run them for free).

share|improve this answer
Will give it a try. – Olav Gausaker Oct 21 '11 at 10:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.