Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're running Plone 4.1, Zope 2.13 behind Apache with mod_proxy_balancer. We have 2 zope instances running 2 threads each.

We're seeing a number of connections between Zope and Apache being ESTABLISHED but never released (or at least they're hanging around a long time).

This is happening on our live and test system. Trying to analyse this on our test system:

pid of one of the zope instances is 17577

# netstat -a -p | fgrep 17577/
tcp        0      0 *:18091                     *:*                         LISTEN      17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:36932 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:36931 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:36929 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:36940 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:36936 ESTABLISHED 17577/python
tcp        0      0 localhost.localdomain:51672 localhost.localdomain:mysql ESTABLISHED 17577/python
tcp        0      0 localhost.localdomain:47304 localhost.localdomain:mysql ESTABLISHED 17577/python
tcp        0      0 localhost.localdomain:47297 localhost.localdomain:mysql ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47559 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47556 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47554 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47552 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47567 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47565 ESTABLISHED 17577/python
tcp        0      0 dev.ic.soschildrensvi:18091 dev.ic.soschildrensvi:47560 ESTABLISHED 17577/python

So 13 connections between Apache and Zope. I make a request to Plone and this increases 16 then 17 then 19. It was up to 88 on one instance and 89 on the other before I restarted them this morning. Apache configuration looks like this

ProxyPreserveHost On
<Proxy balancer://zopes>
  BalancerMember http://dev:18091
  BalancerMember http://dev:18092
</Proxy>
RewriteRule ^/(.*) balancer://zopes/VirtualHostBase/http/%{SERVER_NAME}:%{SERVER_PORT}%{ENV:PLONE_FOLDER_PATH}/VirtualHostRoot/$1 [last,proxy]

The reason I'm posting this is because we're experiencing some connectivity and performance issues on our servers and I'm wondering whether this might be something to do with it.

We also have a separate Plone 3.3 / Zope 2.10 / Apache with no balancer configuration and this doesn't leave any connections lying around.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.