Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using RHEL 4 with the default database installed in there (PostgreSQL 7.4), but I want to have PostgreSQL 8.1 installed. What is best, upgrade it or install a new one?

share|improve this question

migrated from stackoverflow.com Oct 22 '11 at 11:55

This question came from our site for professional and enthusiast programmers.

1  
Neither of which are current by any stretch... –  OMG Ponies Oct 22 '11 at 4:40

3 Answers 3

Why? Both versions are EOL and thus not supported anymore. Even 8.2 will be EOL within months, you need version 9.0 or 9.1

Check http://wiki.postgresql.org/wiki/RPM_Installation for the how-to-install

share|improve this answer
    
i'm just in the progress to replicate the old system at old server to the new one, because the old system was running in RHEL 4 with postgres v.8.1.this system was important.i'm only had RHEL 4 certification so i'm still use this RHEL4 and the maximum version is 8.4.sorry if my english was bad –  why_u Oct 24 '11 at 2:37

You need to upgrade to RHEL 5 or 6. RHEL 5 however will begin the EOL phase out this year and will EOL for regular customers in 2014, with it expiring in 2017 for Extended Life Cycle customers. In addition RHEL6 is much improved in terms of security with SELinux being integrated for almost all applications in addition to improved performance optimization capabilities.

share|improve this answer
    
i dont have RHEL 5 or 6 license, just the RHEL 4.so i just can upgrade to maximum 8.4 version of postgresql –  why_u Oct 24 '11 at 2:38

If you can't upgrade RHEL, you might want to look into switching to CENTOS. If you still can't do that, and must run 8.4 on RHEL4, I would probably compile/install the 8.4 instance from a tarball to a new location, and then use the pg_dump/restore tools to convert the data into the new version of the database.

share|improve this answer
    
i've try to install the 8.4 version but it can't be installed because there is 7.4 version. –  why_u Nov 2 '11 at 2:01
    
If you do this using a tarball and compiling it yourself, your should be able to install it to a different location, without any conflicts. –  xzilla Jan 7 '12 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.