Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In our old Exchange 2003 setup, we had two Exchange servers. Neither one was a front-end server so people on server1 would need to go to https://server1.example.com/Exchange and people on server2 would need to go to https://server2.example.com/Exchange to check their mail (we had friendlier redirects setup). We require SSL on both instances of the webmail.

We are now beginning a transition to Exchange 2007 and a cleaner more user-friendly setup. We currently have the CAS server setup, and everything looks like its working so far at this point except for one little detail. When a legacy user attempts to logon to the CAS server, the CAS server is supposed to automagically switch them over to their appropriate mailbox server. This works to a point...

When a legacy user logs into the CAS server (for example sake the user's mailbox is on server1) the CAS server redirects them after a successful logon to http://server1.example.com/Exchange (note the lack of https). They then get presented with a not so friendly error telling them to use an https connection.

I can't seem to find documentation anywhere on this. Does anyone have any ideas?

Edit: As a clarification I would like the CAS server to correctly redirect to the https page. Could this be a setting on the 2003 servers?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

While this is only a workaround, and I'm not particularily happy about it. For anyone else that has this problem I ended up just disabling the requirement for HTTPS connections on our Exchange 2003 boxes. Only the HTTPS port is still open to the outside world, so the only possible way for people to use the unsecure connection is internal but I'd rather it not be that way at all.

The CAS server is proxy'ing happy now for the 2003 mailboxes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.