Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

params are:

ip: 94.23.147.56 netmask 255.255.255.255 broadcast 94.23.147.56 gw: 176.31.248.254

what's wrong in here? this params works perfectly with debian.. it's not my fault that stupid ovh.co.uk who knows nothing about networking uses this insane params.. but why fsbd dares to validate them... how to setup network in that installation wizard???

Update

I already setuped network, it works with stated configuration. My question was how to enter this configuration to sysinstall utility or atleast how to enable it through holographic shell.

share|improve this question
1  
Your assigned address is in a /32 subnet, and the gateway (which, by definition, must be in the same subnet as the host - this is impossible in a /32) is nowhere near that subnet? I wouldn't validate it either if I were FreeBSD. Where did you get this IP information? –  Shane Madden Oct 24 '11 at 2:27
    
Not only that - the broadcast address is the same as the ip. That's not very likely to be correct as well. –  Rilindo Oct 24 '11 at 2:45
    
This is OVH hosting configuration, it works on debian and this stated in their guide help.ovh.ie/Bridgeclient –  holms Oct 24 '11 at 2:51
add comment

3 Answers

up vote 1 down vote accepted

You can fake it — use wider mask (for e. g., /30 or /29) and choose an IP inside of that sub-network to be your router. Add static arp entry for that IP with MAC address of real gateway. I think it should work then.

Updated: Minimal network would fit is /28: 94.23.147.48/28. 94.23.147.49 can be chosen as default gateway then. Placing ARP entry for it:

arp -s 94.23.147.49 MAC:ADDR:OF:176.31.248.254

— now 94.23.147.49 can be used as default router.

share|improve this answer
    
any examples please? I'm not so skillful =) –  holms Oct 24 '11 at 4:11
    
@holms, added. It's really simple –  poige Oct 24 '11 at 5:50
add comment

How would the host reach the gateway? It's not directly connected to it, and has no route to it. This is a nonsensical configuration.

The configuration page you linked to just has a mistake in it. They used the subnet mask for a failover IP in place of the subnet mask for the primary IP. The subnet mask for the primary IP must be the correct subnet mask for the subnet. And the gateway must be in the same subnet as the primary IP.

share|improve this answer
    
ok tell me how debian works =)? I can paste you configuration. this config is for guest VM machine. all i know that in host machine i added route with failover ip.. and that's it.. vm works with no problem, I know that this configuration is bullshit but it works! now what's wrong with fbsd - i don't know. forum.ovh.co.uk/showthread.php?t=4321 somebody tried to recommend config in here.. too –  holms Oct 24 '11 at 3:41
1  
It sounds like the correct netmask is 255.255.255.0, and the correct gateway in your case is 94.23.147.254. –  David Schwartz Oct 24 '11 at 4:05
    
this doesn't work. I already setuped network, it works with stated configuration. My question was how to enter this configuration to sysinstall utility or atleast how to enable it through holographic shell.. –  holms Oct 24 '11 at 4:07
add comment

The netmask 255.255.255.255 is invalid as it is saying that the entire address is the subnet part. You would need to contact your provider and determin the correct netmask setting. 255.255.255.0 is common.

share|improve this answer
    
as I stated in comment earlier, this works in DEBIAN. here's params from that hosting help.ovh.ie/Bridgeclient you can see there's the whole config for freebsd but how to enter this to INSTALL CD? –  holms Oct 24 '11 at 2:54
    
# ifconfig em0 inet IP.Fail.over netmask 255.255.255.255 broadcast IP.Fail.over # route add -net Your.Server.IP.254/32 IP.Fail.over # route add default Your.Server.IP.254 ifconfig_* variables just contains parameters passed to ifconfig, route_* - to route add –  gelraen Oct 24 '11 at 6:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.