Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is my first question, although I daily read answers here, helps me a great deal. I hope you guys will help me too.

Anyway, here is where I have gotten stuck. I have Nagios server on Ubuntu 10.04.3 LTS \n \l On one of my remote machines (which is also Ubuntu, but version 8.04.4 LTS \n \l), I did setup of SSH password-less settings (installed keys on both machines, work perfectly). But, after adding commands, error is the following:

Remote command execution failed: /usr/local/nagios/libexec/check_disk:    
/lib/tls/i686/cmov/libc.so.6: 
version `GLIBC_2.8' not found (required
by /usr/local/nagios/libexec/check_disk)

Also here is nrpe. cfg from remote machine:

command[check_disk_by_ssh]=/usr/local/nagios/libexec/check_disk -w 20 -c 10 -p /dev/sda1

And, here is settings from Nagios:

Installed libc linux-gate.so.1 => (0x00484000) libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00d8f000) /lib/ld-linux.so.2 (0x005f3000)

        Version information:
        /bin/sh:
                libc.so.6 (GLIBC_2.4) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.3) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.3.4) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.2) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.1) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.11) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.1.1) => /lib/tls/i686/cmov/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/tls/i686/cmov/libc.so.6
        /lib/tls/i686/cmov/libc.so.6:
                ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2

Settings of remotelinux machine on Nagios server:

 define service{

use                             local-service         ; Name of service template to use

host_name                       remote_linux_machine

service_description             Remote check disk

check_command                   check_disk_by_ssh!check_sda1!20%!10%!/

 contact_groups                  admins
 }

And also, commands.cfg:

'check_disk_by_ssh' command definition

define command{

 command_name    check_disk_by_ssh

 command_line    $USER1$/check_by_ssh -H $HOSTADDRESS$ -C "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$"
            }

So, please help me to solve this

share|improve this question

2 Answers 2

up vote 0 down vote accepted

look at this:

/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by usr/local/nagios/libexec/check_disk

which says that the version of glibc on your system is not what is required to run on this machine. so try to remove the nagios plugins and re-install them, which will resolve the dependencies issue.

share|improve this answer

You're mixing up NRPE with check_by_ssh plugin.

Comment out the definition of check_disk_by_ssh on the Nagios server and edit the service definition as belows:

define service{
        use                             local-service         
        host_name                       remote_linux_machine
        service_description             Remote check disk
        check_command                   check_nrpe!check_disk_by_ssh
        contact_groups                  admins
        }

Reload the nagios service and try again.

share|improve this answer
    
Thanks for a quick response, I will do that. –  Zoran Oct 24 '11 at 8:44
    
No changes. Same error appears, when starting any of commands on remote machine, the following error appear: #/usr/local/nagios/libexec# ./check_ssh -H localhost ./check_ssh: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by ./check_ssh) –  Zoran Oct 24 '11 at 10:33
1  
Looks like a bug. Did you try to install nagios plugins from Ubuntu repository? –  quanta Oct 25 '11 at 8:50
    
No, I didn.t. Will try and give you feedback. Thanks again for helping –  Zoran Oct 25 '11 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.