Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I would like to share my www folder on my local machine with others in my office but when I do this and try navigate back to my localhost sites, I get the error HTTP Error 401.3 - Unauthorized.

Now I have done a search already and found this http://forums.iis.net/t/1048841.aspx but it's a bit too technical for my skill level and was hoping someone here might be able to give me an easier way to understand this?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

What it's saying is that after you made this change the permissions on the folder might be off. Make sure that whatever identity is running your application pool in IIS has permissions on the folder.

Also, the event viewer might give you additional details that can confirm this is a permissions issue.

share|improve this answer
    
Thanks Chris, let me try that –  SixfootJames Oct 24 '11 at 13:32
    
I think I might need a step by step on this now as it seems I have busted this right up :-s. Can someone please tell me what all the permissions are I would need on the wwwroot folder once I have shared it with others in my office? Many thanks! –  SixfootJames Oct 24 '11 at 14:29

I had exactly this issue. I resolved it by amending the following:

IIS -> sites -> awebite -> Authentication -> Anonymous Authentication -> edit -> Anonymous User Identity -> set -> username & password

The username should be the computer's owner username. The password should be the computer's owner password. This resolved the problem.

You may also have to add [computer_name]\IIS_IUSRS to the security tab list of the website physical folder, by right clicking on the folder and choosing properties -> security -> add.

It is shame that Windows does not warn you that by sharing a web directory, you will need to make the appropriate changes in IIS. Would be helpful. I wasted a couple of hours trying to figure this out.

share|improve this answer

Add authenticated users, in security tab. when ever you share an folder, it overwrites the fake share that is link to IIS Snap in User. share your Folder, re-add authenticated users (all options ecept full control, special permissions, add IIS_IUSRS read execute, list folder contents, read.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.