Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've currently tried to setup a webserver on my Fedora 15 machine to run content management systems locally. My purpose for this is to gain some experience with administration of webservers.

However, i've run into a problem when trying to install/configure AdaptCMS 2.0.1. I've placed AdaptCMS2/ in /var/www/html/ as specified by documents, but I cannot access the directory files through Firefox 7.0.1

localhost/AdaptCMS2/install.php

Firefox loads this URL for abit, then returns with a "Server not found" page. Saying...

Firefox can't find the server at www.localhost.

I searched around on the Internet, and tried editting about:config, variable: browser.fixup.alternate.enable so that Firefox wouldn't resolve localhost into www.localhost[.com]/, but it doesn't seem to work at all. So I guessed it had to be some other issue.

I therefore tried making a test.php file in /var/www/html/ by itself. It simply runs phpinfo();

localhost/test.php

Returns the expected result.

But here's the part where I narrowed it down; When I tried doing...

localhost/AdaptCMS2/install.ph

It returned a completely different error, saying:

The requested URL /AdaptCMS2/install.ph was not found on this server.

Along with the serverinfo footer from Apache. So it seems the server is fine.

I've been trying to fix this problem for an hour now, and I can't grasp what I am supposed to do, in order to get it to access files in AdaptCMS2/ directory. I'm completely clueless. Help!

share|improve this question
    
You are running the Webserver and the Webbrowser on the same machine? –  mailq Oct 24 '11 at 14:27
    
Sounds like a bug in the CMS. –  Ignacio Vazquez-Abrams Oct 24 '11 at 14:36
    
Yeah, i'm running the whole thing on the same machine. –  Christopher Jacobsen Oct 24 '11 at 15:04
add comment

1 Answer

up vote 0 down vote accepted
Firefox can't find the server at www.localhost

Type URL explicitly: http://localhost/AdaptCMS2/install.php , Firefox is trying to access non-existing site www.localhost

The requested URL /AdaptCMS2/install.ph was not found on this server.

If this isn't typo in answer, your should change install.ph to install.php

Are unix rights on AdaptCMS2 folder and it's files correct? Can apache user have access to it?

Try to place static html file in AdaptCMS2 folder and to access it. If static HTML works fine, you may have improperly configured php, otherwise you have problems with file rights or improper configuration.

share|improve this answer
    
Running the explicit URL did not work, and returned the same result as with running without http... I used install.ph as a test to see whether or not the server did infact run. –  Christopher Jacobsen Oct 24 '11 at 14:53
    
I tried doing chmod 777 on AdaptCMS2/, but it still doesn't work. Apache user's home directory is /var/www, so it should work? I figured that giving full permissions for all users to that directory would fix the problem (chmod 777) but apparently not. :( –  Christopher Jacobsen Oct 24 '11 at 15:03
    
You marked this answer as accepted, but didn't write anything. Did it help? –  Selivanov Pavel Oct 24 '11 at 19:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.