Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
Sysprep Fails when creating a new Template in Microsoft Virtual Machine Manager:

Error (706) 
Sysprep failed for virtual machine VMName 

Recommended Action 
Try the operation again.

Is there a more detailed log available for this error? This error is not helpful. This same configuration worked previously, but now fails consistently.

Update

The issue was that the VHD was locked by another process. Cloning and sysprepping the clone worked fine.

share|improve this question
    
I don't use sysprep, since I deploy thin images, so I may be wrong, but shouldn't you sysprep a machine before you image/clone it and not part of the post-deployment workflow? –  MDMarra Oct 24 '11 at 19:52
    
From the wording of the question, I inferred that the OP had a VM, installed Windows in it and was preparing to sysprep that Windows instance for imaging. That's how I managed imaging because it was far easier to just snapshot before making changes. It was a huge time-saver in the case of a mistake or a later change. –  Ben Campbell Oct 24 '11 at 20:49
    
Did you solve this issue? Any more info to add? –  Ben Campbell Oct 30 '11 at 2:41
add comment

1 Answer

Have you checked your rearm count? You only get 4 (considering you're using something newer than XP). Check your rearms by running this in a command prompt (run as admin):

slmgr /dlv

I also remember seeing something about stopping services when I used to image in Fusion (yes, I built Windows images on a Mac!) Check into the Media Sharing service and see if stopping it makes a difference.

Here are log file locations for different sysprep options:

  • generalize: %WINDIR%\System32\Sysprep\Panther
  • specialize: %WINDIR%\Panther
  • Unattended Windows setup actions: %WINDIR%\Panther\Unattendgc

Hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.