Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to have a homepage running on my Mac that external users can use. I thought the easiest way, was to make Apache Tomcat running on port 80. But when i try it says that the port are in use.

I can't see anything that are using port 80.

What to do???

share|improve this question
    
Are you starting it up using " sudo catalina.sh start " ? –  mahnsc Oct 25 '11 at 12:06
    
That solve the problem :) Thanks –  boje Oct 25 '11 at 16:19

2 Answers 2

up vote 1 down vote accepted

Since Tomcat is listening on port 80, you need to start it up using sudo. For example: sudo catalina.sh start

(I already answered this in the comment above but figured I should submit an answer for completeness)

share|improve this answer

OSX comes with a built-in Apache, which is probably enabled.

Got to "system preferences"->"sharing"->"file & web"->"Web sharing"

Make sure web sharing is disabled.

share|improve this answer
    
Web sharing are OFF.. THis does not support Java/JSP/Servlet so i need to make my own. –  boje Oct 25 '11 at 10:09
    
What's the output of this command "lsof -i :80"? It's possible you have to run this as root (sudo). –  Jeroen Jacobs Oct 25 '11 at 11:54
    
Code: (see the picture) link –  boje Oct 25 '11 at 12:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.